Swisslinux.org

− The GNU/Linux crossroads in Switzerland −

 

Language

 

The Forum

You are not logged in.

#1 07 Jun 2022 09:53:42

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2736
Website

Paketsystem beschädigt auf P775DM3 mit Ubuntu 20.04

Guten Tag,

Ein Kunde, der uns letztens ein why! P775DM3-G mit Ubuntu 20.04 bestellt hat, schreibt uns folgendes:

Beim Software Update erhalte ich folgende Fehlermeldung:


https://blog.whyopencomputing.ch/wp-content/uploads/2022/06/2022.06.04_Paketsystem_beschädigt.png

Wenn ich den empfohlenen Befehl apt-get install -f ausführe, erhalte ich folgende Meldung:

Code:

dk@dk-P7xxDM3-G:~$ apt-get install -f
E: Sperrdatei /var/lib/dpkg/lock-frontend konnte nicht geöffnet werden. - open (13: Keine Berechtigung)
E: Erlangen der Sperre für die Dpkg-Oberfläche (/var/lib/dpkg/lock-frontend) nicht möglich; sind Sie root?


apt-get update gibt folgendes Ergebnis:

Code:

dk@dk-P7xxDM3-G:~$ apt-get update
Paketlisten werden gelesen... Fertig
E: Sperrdatei /var/lib/apt/lists/lock konnte nicht geöffnet werden. - open (13: Keine Berechtigung)
E: Das Verzeichnis /var/lib/apt/lists/ kann nicht gesperrt werden.
W: Problem beim Entfernen (unlink) der Datei /var/cache/apt/pkgcache.bin - RemoveCaches (13: Keine Berechtigung)
W: Problem beim Entfernen (unlink) der Datei /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Keine Berechtigung)

Könnten Sie mir dabei helfen?


laptop why! NV41MZ, Intel Core i7-1165G7, RAM 16 Gb, Ubuntu 22.04 LTS

Offline

 

#2 07 Jun 2022 09:58:04

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2736
Website

Re: Paketsystem beschädigt auf P775DM3 mit Ubuntu 20.04

Um root zu sein, muss dem Befehl sudo vorangestellt werden, gefolgt von dem blind eingetippten Passwort.

Bei allen Vorgängen, die mit Softwareaktualisierungen zu tun haben, muss sudo vorausgehen.


laptop why! NV41MZ, Intel Core i7-1165G7, RAM 16 Gb, Ubuntu 22.04 LTS

Offline

 

#3 07 Jun 2022 23:45:10

jean@adimp.ch
Illuminé(e)
From: Marly
Registered: 10 Mar 2005
Posts: 1223
Website

Re: Paketsystem beschädigt auf P775DM3 mit Ubuntu 20.04

Hallo,
Ich würder zuerst libc6 deinstallieren mit ein "apt-get purge libc6".
Grüsse.
Jean.


--------------------------------------------------------
Jean Tinguely Awais
Ma vie sur twitter : http://www.twitter.com/tservi

Offline

 

Board footer

Powered by FluxBB