Swisslinux.org

− The GNU/Linux crossroads in Switzerland −

 

Language

 

The Forum

You are not logged in.

#1 10 Nov 2020 08:56:20

wrossell
Apôtre du libre
 
Registered: 30 Jul 2015
Posts: 60

[Résolu] Ubuntu 20.04: quelle version de Wine faut-il installer?

Bonjour,

Depuis que je suis passé à la version 20.04 d'Ubuntu, les logiciels fonctionnant avec Wine ne réagissent plus.

Existe-t-il une version de Wine compatible avec Ubuntu 20.04?
Si oui, est-elle disponible dans l'offre des logiciels à installer ou faut-il la télécharger de quelque part et l'installer autrement?

Merci d'avance et cordiales salutations,
walter

Offline

 

#2 10 Nov 2020 09:39:19

Eggman
Admin
From: Grand-Lancy(GE)
Registered: 17 Nov 2004
Posts: 1057
Website

Re: [Résolu] Ubuntu 20.04: quelle version de Wine faut-il installer?

Bonjour,

Je ne suis pas totalement sûr de la source de votre problème.

Pouvez vous me dire ce que renvoie la commande suivante, à taper dans votre terminal:

Code:

dpkg -l *wine*

"It always takes longer than you expect, even when you take into account Hofstadter's Law."
Douglas Hofstadter, Gödel, Escher, Bach: An Eternal Golden Braid

Offline

 

#3 10 Nov 2020 09:59:11

wrossell
Apôtre du libre
 
Registered: 30 Jul 2015
Posts: 60

Re: [Résolu] Ubuntu 20.04: quelle version de Wine faut-il installer?

Le terminal indique: besoin de réinstallation. J'aimerais bien vous copier tout ce qu'il indique en plus, mais je ne suis pas à l'aise avec le terminal et ne sais pas comment copier son contenu.

Wine (5.0-3ubuntu1) est pourtant donné comme installé dans la liste des logiciels.

Last edited by wrossell (10 Nov 2020 10:03:59)

Offline

 

#4 10 Nov 2020 11:14:03

Eggman
Admin
From: Grand-Lancy(GE)
Registered: 17 Nov 2004
Posts: 1057
Website

Re: [Résolu] Ubuntu 20.04: quelle version de Wine faut-il installer?

Vous pouvez sélectionner avec la souris le contenu du terminal, puis faire un clic droit pour copier, puis coller le contenu dans un message ici ou le sauver préalablement dans un ficher texte.

La sortie de cette commande est importante pour diagnostiquer le problème.


"It always takes longer than you expect, even when you take into account Hofstadter's Law."
Douglas Hofstadter, Gödel, Escher, Bach: An Eternal Golden Braid

Offline

 

#5 11 Nov 2020 08:35:31

wrossell
Apôtre du libre
 
Registered: 30 Jul 2015
Posts: 60

Re: [Résolu] Ubuntu 20.04: quelle version de Wine faut-il installer?

Bonjour,

Merci de votre disponibilité. Voici ce que le terminal m'indique:

Code:

walter@walter-W840AU:~$ dpkg -l *wine*
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=att>
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                  Version              Architecture Description
+++-====================-====================-============-====================>
ii  fonts-wine           5.0-3ubuntu1         all          Windows API implemen>
rc  libkwineffects1abi4  4:4.11.11-0ubuntu0.2 amd64        library used by effe>
ii  libwine:amd64        5.0-3ubuntu1         amd64        Windows API implemen>
un  q4wine               <aucune>             <aucune>     (aucune description >
ii  wine                 5.0-3ubuntu1         all          Windows API implemen>
un  wine-amd64           <aucune>             <aucune>     (aucune description >
un  wine-binfmt          <aucune>             <aucune>     (aucune description >
un  wine-gecko           <aucune>             <aucune>     (aucune description >
ii  wine-gecko2.21:amd64 2.21-0ubuntu1        amd64        Microsoft Windows co>
ii  wine-gecko2.21:i386  2.21-0ubuntu1        i386         Microsoft Windows co>
un  wine-mono            <aucune>             <aucune>     (aucune description >
ii  wine-mono0.0.8       0.0.8-0ubuntu1       all          Microsoft Windows co>
ii  wine-stable          3.0.1ubuntu1         all          Windows API implemen>
un  wine1.0              <aucune>             <aucune>     (aucune description >
un  wine1.2              <aucune>             <aucune>     (aucune description >
un  wine1.3              <aucune>             <aucune>     (aucune description >
un  wine1.4              <aucune>             <aucune>     (aucune description >
un  wine1.4-amd64        <aucune>             <aucune>     (aucune description >
un  wine1.5              <aucune>             <aucune>     (aucune description >
un  wine1.5-amd64        <aucune>             <aucune>     (aucune description >
ii  wine1.6              1:1.8.4ubuntu1       amd64        Windows API implemen>
ii  wine1.6-amd64        1:1.8.4ubuntu1       amd64        Windows API implemen>
un  wine1.7              <aucune>             <aucune>     (aucune description >
un  wine1.7-amd64        <aucune>             <aucune>     (aucune description >
un  wine1.8              <aucune>             <aucune>     (aucune description >
un  wine1.8-amd64        <aucune>             <aucune>     (aucune description >
un  wine1.9              <aucune>             <aucune>     (aucune description >
un  wine1.9-amd64        <aucune>             <aucune>     (aucune description >
un  wine32               <aucune>             <aucune>     (aucune description >
ii  wine64               5.0-3ubuntu1         amd64        Windows API implemen>
un  wine64-preloader     <aucune>             <aucune>     (aucune description >
ii  winetricks           0.0+20200412-1       all          simple tool to work >
lines 15-37/37 (END)

Bien à vous,
walter

Offline

 

#6 11 Nov 2020 12:12:55

Eggman
Admin
From: Grand-Lancy(GE)
Registered: 17 Nov 2004
Posts: 1057
Website

Re: [Résolu] Ubuntu 20.04: quelle version de Wine faut-il installer?

Bonjour,

J'ai compris où se trouve le soucis.
Pour faire court, et comme je m'en doutais, Ubuntu 20.04 installe par défaut la version 64 bits de wine et ne prend pas en compte l'architecture 32 bits. Or pour que cela fonctionne correctement, il vous faut surtout la version 32bits.
De plus, il reste pas mal de paquets reliques des versions précédentes d'Ubuntu, ce qui peut compliquer la chose.

Il est possible et simple de régler ces soucis.
Dans l'absolu, il serait élégant de supprimer ces reliques, mais je vais commencer par vous guider pour installer la version 32bits de wine

Dans la grandes lignes, il y a trois étapes:
* demander au gestionnaire de paquets de prendre en compte les paquets 32 bits
* rafraîchir la liste des paquets
* installer la version 32bits de wine

En détail:

1. Rajout de l'architecture 32bits
Dans le terminal, tapez ce qui suit:

Code:

sudo dpkg --add-architecture i386

2. Rafraîchissement de la liste des paquets
Tapez ensuite:

Code:

sudo apt update

3. Installation de wine 32bits
Tapez finalement:

Code:

sudo apt install wine32

Cela devrait installer wine 32bits et toutes ces dépendances à côté de wine 64bits.
Normalement, tout devrait bien se passer.

Une fois cela fait, vous devriez pouvoir utiliser vos programmes installés avec wine.

N'hésitez pas à commenter en cas de pépins … ou de réussite ! smile


"It always takes longer than you expect, even when you take into account Hofstadter's Law."
Douglas Hofstadter, Gödel, Escher, Bach: An Eternal Golden Braid

Offline

 

#7 17 Nov 2020 15:04:54

wrossell
Apôtre du libre
 
Registered: 30 Jul 2015
Posts: 60

Re: [Résolu] Ubuntu 20.04: quelle version de Wine faut-il installer?

Yesss, merci infiniment, wine revit.

Cordiales salutations,
walter

Offline

 

#8 17 Nov 2020 17:50:09

Eggman
Admin
From: Grand-Lancy(GE)
Registered: 17 Nov 2004
Posts: 1057
Website

Re: [Résolu] Ubuntu 20.04: quelle version de Wine faut-il installer?

Content d'avoir pu vous aider!


"It always takes longer than you expect, even when you take into account Hofstadter's Law."
Douglas Hofstadter, Gödel, Escher, Bach: An Eternal Golden Braid

Offline

 

#9 24 Nov 2020 21:48:58

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2132
Website

Re: [Résolu] Ubuntu 20.04: quelle version de Wine faut-il installer?

Content aussi de savoir que Eggman a trouvé une solution!

Cordialement.


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Offline

 

Board footer

Powered by FluxBB