Swisslinux.org

− The GNU/Linux crossroads in Switzerland −

 

Language

 

The Forum

You are not logged in.

  • Index
  •  » Ubuntu
  •  » [HARDW] Problème d'installation d'ubuntu

#1 08 Aug 2005 18:43:46

ReWinD
Citoyen(ne)
 
Registered: 17 Jan 2005
Posts: 22

[HARDW] Problème d'installation d'ubuntu

Salut la foule,
me revoici avec un problème bien spécial que, j'espère, certains d'entre vous ont certainement dû avoir .

Je m'explique,
j ai un nouveau PC fraichement monté :


config ==>
P4 3ghz [630] FSB800
Carte mère Asus P5GDC-V Deluxe
2 * 1Gb de RAM PC3200
1 * DD IDE Samsung 120Go
2 * DD IDE Samsung 160Go en RAID
1 * DVD-RW Plextor PX-716A
(inutil de préciser le reste de la config)

Voilà mon souci, j'ai mon disque dur principal monté sur la Nappe 1 en master, mon Graveur DVD en slave car je n ai nul autre choix, les 2 autres ports IDE étant des RAID gérés par un chipset controleur RAID "promise".
Ce qui veux dire que dans mon BIOS je n'ai pas la possibilité de choisir les périphériques branchés au contrôleurs IDE "promise" comme periph d'amorçage.

C'est là que mon problème réside. Ubuntu lors de l'installation, boote normalement depuis le graveur qui est en SLAVE mais  lors de l'initialisation de mes periphériques, il me demande a chaque fois d'installer les pilotes du graveur DVD et ne le reconnais même pas en tant que lecteur CD simple, au minimum.

J'ai essayé de monter le plextor en MASTER et mettre le disque dur principal sur la même nappe en SLAVE, mais rien n'y fait.

Je n'ai aucun pilote pour ce graveur DVD et je tourne en boucle lorsque j'essaie d'aller plus loin...

Que faire..!?

Je vous remercie sincèrement pour toute vos réponses quelles qu'elles soient. (sauf si c est une insulte biensûr :p )

Offline

 

#2 08 Aug 2005 19:02:46

BOFH
Admin
From: Ecublens, VD
Registered: 03 Feb 2005
Posts: 862
Website

Re: [HARDW] Problème d'installation d'ubuntu

Hello,

  Je connais pas assez bien Ubuntu pour te donner une réponse détaillée, mais il y a quand même une question que je me pose: pourquoi voudrais-tu amorcer le système sur les disques en raid, si tu disposes d'un autre disque a côté ? le disque de 120 gigs ne fait pas l'affaire comme disque système ?

  Ensuite, pour le problème de driver du graveur, ca me paraitrait étrange qu'il ne fonctionne pas en lecteur simple avec le driver atapi standard; as-tu essayé le mode d'installation expert, en ignorant simplement le problème lié au driver du graveur ?

  Si quelqu'un qui connait Ubuntu pouvait lui répondre plus en détail... ?

Offline

 

#3 08 Aug 2005 19:24:33

ReWinD
Citoyen(ne)
 
Registered: 17 Jan 2005
Posts: 22

Re: [HARDW] Problème d'installation d'ubuntu

Merci de te pencher sur mon cas,
en fait en 2 mots, je suis presque sûr que si j'avais un controleur secondaire, mon BIOS me permettant de booter sur celui ci, je n'aurais aucun problème.

Car à mon sens, il pars en vrille du fait que le fameux DD de 120Go (celui qui sera le "hda")et le Graveur sont physiquement sur la même nappe.

A mon avis, Ubuntu se perds tout simplement, je me trompe peut être mais c'est un raisonnement intuitif puisque c est tout ce qu il me reste wink

Et pour l'installation mode expert, il ne m'en donne pas la possibilité, de plus, pour finir l installation, il essaie de chercher les infos sur le CD mais ne peut pas puisqu'il ne trouve plus ce dernier...

P.S : J'ai essayé avec les drivers standards mais il tourne tjrs en boucle sur le menu detection automatique des Cederoms... Je viens de faire l essaie avec un lecteur de CDroms simple et même soucis...!

Offline

 

#4 08 Aug 2005 21:21:49

BOFH
Admin
From: Ecublens, VD
Registered: 03 Feb 2005
Posts: 862
Website

Re: [HARDW] Problème d'installation d'ubuntu

Hmmm... en tout cas, si l'installeur boote correctement, c'est que le BIOS n'a pas de problèmes pour accéder au disque en question.. mais le noyau lui-même n'utilise pas la même méthode d'accès, ce qui pourrait expliquer ton problème... A tout hasard, as-tu vérifié la position des cavaliers sur les deux drives qui se partagent la nappe primaire ?

Il me semblait pourtant qu'il y avait une méthode d'installation "expert" dans ubuntu, as-tu essayé d'appuyer sur F1, F2, ... a l'invite du bootloader (avant le chargement du noyau) ? il devrait y avoir des pages d'aides pour les modes d'installation spéciaux. Tu devrais pouvoir sauter l'étape qui te dérange. Pendant l'installation, tu devrais aussi pouvoir basculer entre plusieurs consoles virtuelles avec Alt-F1, Alt-F2, etc... ce qui devrait te permettre de mettre l'installeur de côté et de travailler a la main depuis un shell. A ta place, j'essaierai de sauter l'étape de chargement des drivers, et de monter directement le CD a la main avec quelque chose comme

Code:

# mount /dev/hdb /mnt/cdrom

en remplaçant /mnt/cdrom par la ou Ubuntu s'attend a trouver le CD (connais pas Ubuntu...)

Offline

 

#5 09 Aug 2005 00:15:35

Daoro
Gourou(e) du libre
 
From: Givisiez (FR)
Registered: 17 Nov 2004
Posts: 478
Website

Re: [HARDW] Problème d'installation d'ubuntu

Etonnant parce que je ne vois pas ce qui pourrait poser problème.
Asus était un temps réputé comme "peu compatible Linux", et je pensais que c'était révolu. A voir ce n'est pas le cas.

Juste pour voir, c'est quoi le chipset de la carte mère ? Du i9xx ? (j'ai la flemme de chercher ^^)


http://misc.daoro.net/daoro.gif

Offline

 

#6 09 Aug 2005 10:20:23

ReWinD
Citoyen(ne)
 
Registered: 17 Jan 2005
Posts: 22

Re: [HARDW] Problème d'installation d'ubuntu

Ok merci encore, ben après toutes ces réponses je vais faire encore les essais proposés, mais apparemment, ce n'est pas encore au point niveau compatibilité, effectivement.

C est quand même fou, j ai regardé sur le CD Asus hier pour voir si il y avait des drivers IDE pour linux avec ce chip qui est le i915P, mais rien...

Si je dois recommander une autre carte mère parce qu'en l'an 2005 Asus ne sont pas foutus d avoir des drivers linux, alors que cet OS formidable se démocratise, je trouve que c est un poil la honte quand même !?

Je vous tiens au courant

Edit : je crois que mon noyau est trop vieu depuis le CD ISO de Hoary, il me faudrais un kernel 2.6.11.11 minimum

Offline

 

#7 09 Aug 2005 11:19:04

Daoro
Gourou(e) du libre
 
From: Givisiez (FR)
Registered: 17 Nov 2004
Posts: 478
Website

Re: [HARDW] Problème d'installation d'ubuntu

C'est bizarre parce que j'ai installé Ubuntu sans souci sur un i915, carte mère intel.  :shock:


http://misc.daoro.net/daoro.gif

Offline

 

#8 09 Aug 2005 14:17:48

ReWinD
Citoyen(ne)
 
Registered: 17 Jan 2005
Posts: 22

Re: [HARDW] Problème d'installation d'ubuntu

Mais bien a partir du CD ?

en effet c est bizarre, ou ptet que les drivers diffèrent légèrement, moi c est une I915P, mais en tout cas je pense que ça doit tourner la autour, c est quoi ta carte mère?

Offline

 
  • Index
  •  » Ubuntu
  •  » [HARDW] Problème d'installation d'ubuntu

Board footer

Powered by FluxBB