Swisslinux.org

− The GNU/Linux crossroads in Switzerland −

 

Language

 

The Forum

You are not logged in.

  • Index
  •  » Slackware
  •  » [Xorg] Problème de résolution d'écran (abandoné)

#1 11 May 2005 12:45:59

saintshakajin
Prêcheu(r|se) du libre
 
Registered: 03 Feb 2005
Posts: 182

[Xorg] Problème de résolution d'écran (abandoné)

Hello,

Bon, voilà, j'ai XOrg 6.8.2 sur une Slack Current et le problème étant que si je me mets en 1280*1024 tout s'affiche bien mais j'ai un problème avec les polices, il me manque des "lettres", par exemple lol donnera o mais le o n'est pas entier.
Par contre, là, je suis en 1024*768 et aucun problème sauf que c'est 100x fois trop grand, gros (écran 19").

Section "Monitor"
    Identifier  "My Monitor"
    HorizSync   30-86
    VertRefresh 50-160
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "** NVIDIA (generic)                   [nv]"
    Monitor     "My Monitor"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection

Les drivers nVidia sont correctement installé mais je ne sais pas d'où ça pourrait venir.

Merci de l'aide smile


Debian Sid - XOrg 6.9 - KDE 3.5.0 - Kernel 2.6.15-ck2

Offline

 

#2 11 May 2005 18:36:45

loblique
Citoyen(ne)
 
Registered: 09 May 2005
Posts: 26
Website

Re: [Xorg] Problème de résolution d'écran (abandoné)

Salut,
Je remarque que tu as une carte vidéo NVIDIA, est-ce que tu as installé le pilote avec ton kernel actuel ? Il semble que tu utilises le pilote nv.

D'autre part, à quoi te sert l'option :

ViewPort 0 0

dans tes display ?


loblique,
Slackware 10.1 - kernel 2.6.10
contact jabber
loblique@jabberafrica.org

site en construction :
http://www.loblique.net

Offline

 

#3 12 May 2005 18:40:01

SpitFire
Affranchi(e)
 
From: Ecublens (VD)
Registered: 18 Nov 2004
Posts: 9

Re: [Xorg] Problème de résolution d'écran (abandoné)

peut être tu peux poster un extrait de screenshot qu'on se rende bien compte du problème ?

en tout cas, vérifie que les 75 et 100dpi sont chargées dans la section "Files" du xorg.conf, et qu'il y a qqch dans les répertoires correspondants,

Code:

Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath   "/usr/X11R6/lib/modules"
        FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
        FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
        FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
        FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
        FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

avec les modules "type1" et "freetype" dans la section "Module".

Offline

 

#4 12 May 2005 21:29:26

saintshakajin
Prêcheu(r|se) du libre
 
Registered: 03 Feb 2005
Posts: 182

Re: [Xorg] Problème de résolution d'écran (abandoné)

Voici mon xorg.conf complet.
Je l'ai obtenu avec la commande /usr/X11R6/bin/xorgconfig, donc c'est générique.

saintshakajin@LeGuerrierLegendaire:~$ glxinfo |grep -i ender
direct rendering: Yes
OpenGL renderer string: GeForce4 MX 420/AGP/SSE/3DNOW!

saintshakajin@LeGuerrierLegendaire:~$ lsmod |grep nv
nvidia               3646012  12

ça répond à la question de si mes drivers sont correctement installés et utilisés smile

saintshakajin@LeGuerrierLegendaire:~$ ls /usr/X11R6/lib/X11/|grep rgb
rgb.txt

Je n'ai que ça, est-ce normal?

saintshakajin@LeGuerrierLegendaire:~$ ls /usr/X11R6/lib/X11/fonts/CID/
fonts.dir  fonts.scale
saintshakajin@LeGuerrierLegendaire:~$ ls /usr/X11R6/lib/X11/fonts/Speedo/
saintshakajin@LeGuerrierLegendaire:~$

Voilà ce qui est vide ou bizarre.
Le Viewport, comme xorgconfig me l'a donné je ne l'ai pas supprimé mais je sais même pas à quoi il sert.

Voici une screenshot.

Sinon, le 1280*960 aucun problème mais j'aimerais savoir pourquoi le 1280*1024 ne va pas...


Debian Sid - XOrg 6.9 - KDE 3.5.0 - Kernel 2.6.15-ck2

Offline

 

#5 15 May 2005 15:46:46

loblique
Citoyen(ne)
 
Registered: 09 May 2005
Posts: 26
Website

Re: [Xorg] Problème de résolution d'écran (abandoné)

est-ce que tu as l'antialias d'actif ou non ?


loblique,
Slackware 10.1 - kernel 2.6.10
contact jabber
loblique@jabberafrica.org

site en construction :
http://www.loblique.net

Offline

 

#6 15 May 2005 19:26:21

saintshakajin
Prêcheu(r|se) du libre
 
Registered: 03 Feb 2005
Posts: 182

Re: [Xorg] Problème de résolution d'écran (abandoné)

comment le savoir?


Debian Sid - XOrg 6.9 - KDE 3.5.0 - Kernel 2.6.15-ck2

Offline

 

#7 15 May 2005 23:23:14

Neo
Prêcheu(r|se) du libre
 
From: Sion
Registered: 06 Oct 2004
Posts: 234
Website

Re: [Xorg] Problème de résolution d'écran (abandoné)

Au risque de jouer la rallonge... Installe le driver de Nvidia pour linux.

Tu aura déjà le driver optimisé pour ta carte. De plus tu as accès aux paramètres via la commande nvidia-settings en console.

vala.


La Vérité est Ailleurs...

Offline

 

#8 16 May 2005 00:06:24

saintshakajin
Prêcheu(r|se) du libre
 
Registered: 03 Feb 2005
Posts: 182

Re: [Xorg] Problème de résolution d'écran (abandoné)

Une moitié de ton post j'y ai déjà répondu 2 fois mais l'autre je regarde de suite. Je n'ai jamais eu besoin d'aller dans nvidia-settings mais comme on dit, il y a un début à tout smile

Edit:
C'était l'antialiasing par contre question qui s'impose, les différents modes correspodent à quoi:
2X Bilinear =? 2X Quincunx=? et 2X2 Supersampling =?
Sinon, c'est tout de suite plus clair (pour amsn, ça je ne sais pas encore, pas de contact vivant  :cry: )
Autre question qui découle, l'antialiasing peut aussi se configurer dans le xorg.conf?

Re-Edit
Après test, c'est l'Antialias de Fluxbox qui fonctionne. J'ai beau coché celui de nvidia-settings mais aucune différence et pour être sûr, je restart même X  :cry: Bref, à moitié résolu. Un bon début...

Edit toujours
Amsn est correct dans ses polices, je sais de nouveau lire ce qu'on m'écrit sans devoir faire un tail -f des logs wink
Par contre, qi qqn avait une explication pour les différents tiens indiquer plus haut, ce serait cool smile Sinon, là, j'ai laissé l'antialiasing de fluxbox et celui de nVidia pour être certain smile


Debian Sid - XOrg 6.9 - KDE 3.5.0 - Kernel 2.6.15-ck2

Offline

 

#9 22 May 2005 13:07:07

saintshakajin
Prêcheu(r|se) du libre
 
Registered: 03 Feb 2005
Posts: 182

Re: [Xorg] Problème de résolution d'écran (abandoné)

Je suis repassé à KDE et ce problème de fonts est toujorus rpésent mais pas omniprésent comme sous Flux (qui se corrigeait avec son antialiasing). Là, j'ai bien l'antialiasing de nVidia coché (dans nvidia-settings) mais aucune différence, amsn est toujorus strange et certaines polices sont vraiment pas belle. Il y a pas moyen de mettre l'antialiasing dans xorg.conf par exemple?


Debian Sid - XOrg 6.9 - KDE 3.5.0 - Kernel 2.6.15-ck2

Offline

 

#10 25 May 2005 15:33:36

asteroid
Humain(e) libre
 
From: Sud france - Nîmes (30)
Registered: 30 Dec 2004
Posts: 44
Website

Re: [Xorg] Problème de résolution d'écran (abandoné)

salut.

Tu sembles avoir dri et le pilote 'nvidia' .... ca colle pas.

saintshakajin@LeGuerrierLegendaire:~$ glxinfo |grep -i ender
direct rendering: Yes
OpenGL renderer string: GeForce4 MX 420/AGP/SSE/3DNOW!

Or ta conf semble bonne :

     Load       "glx"
#    Load       "dri"

cheche ptet de ce cote la.

As tu essaye sans le driver 'nvidia' mais avec 'nv' ? ou meme 'vesa' afin de savoir si c'est un soucis de drivers ou si on apelle Mulder et Scully wink


Free Your mind, Free Your Engine ... Get a Slackware !!

Offline

 

#11 26 May 2005 09:01:08

saintshakajin
Prêcheu(r|se) du libre
 
Registered: 03 Feb 2005
Posts: 182

Re: [Xorg] Problème de résolution d'écran (abandoné)

ça me le faisait aussi aussi avec "nv".
Pour ta remarque sur dri, regarde

saintshakajin@LeGuerrierLegendaire:~$ glxinfo |grep ender
direct rendering: Yes
OpenGL renderer string: GeForce4 MX 420/AGP/SSE/3DNOW!

Je l'ai aussi là et je suis sur une Debian.
Je sais pas d'où ça pourrait venir et là, bah ça restera une question en suspend car j'ai supprimé Slack au profit de Debian.
Je sais que l'antialiasing de Fluxbox corrigeait pas celui de nVidia (où je ne vois même pas la différence) et comme KDE n'a pas cette option...
Enfin bref, sujet abandonné.


Debian Sid - XOrg 6.9 - KDE 3.5.0 - Kernel 2.6.15-ck2

Offline

 
  • Index
  •  » Slackware
  •  » [Xorg] Problème de résolution d'écran (abandoné)

Board footer

Powered by FluxBB