Swisslinux.org

− The GNU/Linux crossroads in Switzerland −

 

Language

 

The Forum

You are not logged in.

  • Index
  •  » Debian
  •  » Problème wget avec debian 10 / Buster

#1 20 Jan 2020 21:54:08

Didier100
Prêcheu(r|se) du libre
 
Registered: 11 Aug 2005
Posts: 136

Problème wget avec debian 10 / Buster

Bonjour,

Quand j’exécute la commande:

wget https://files.phpmyadmin.net/phpMyAdmin … ges.tar.gz
le téléchargement n'est pas effectué!

Code:

root@debian:~# wget https://files.phpmyadmin.net/phpMyAdmin/4.9.4/phpMyAdmin-4.9.4-all-languages.tar.gz
--2020-01-20 21:24:52--  https://files.phpmyadmin.net/phpMyAdmin/4.9.4/phpMyAdmin-4.9.4-all-languages.tar.gz
Résolution de files.phpmyadmin.net (files.phpmyadmin.net)… 185.93.2.15
Connexion à files.phpmyadmin.net (files.phpmyadmin.net)|185.93.2.15|:443…

A la fin j'ai un time out ...

puis quand je change le lien par exemple:
wget https://portail.free.fr/content/uploads … 045437.jpg

tout ce passe bien

Code:

root@debian:~# wget https://portail.free.fr/content/uploads/cache/2019/02/shutterstock-229323511/2877045437.jpg
--2020-01-20 21:28:05--  https://portail.free.fr/content/uploads/cache/2019/02/shutterstock-229323511/2877045437.jpg
Résolution de portail.free.fr (portail.free.fr)… 2a01:e0c:1::1, 212.27.48.10
Connexion à portail.free.fr (portail.free.fr)|2a01:e0c:1::1|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 31953 (31K) [image/jpeg]
Sauvegarde en : « 2877045437.jpg »

2877045437.jpg                                              100%[========================================================================================================================================>]  31,20K  --.-KB/s    ds 0,03s

2020-01-20 21:28:05 (1,07 MB/s) — « 2877045437.jpg » sauvegardé [31953/31953]

root@debian:~#

Alors je suppose que c'est liée au port 443 ....

pour tant quand je fait:
wget https://www.google.com -O -

la page est bel et bien téléchargé correctement.

L'ajout de l'option --secure-protocol=SSLv3 ne change rien !

Merci d'avance pour votre aide.

Offline

 

#2 20 Jan 2020 22:09:36

Didier100
Prêcheu(r|se) du libre
 
Registered: 11 Aug 2005
Posts: 136

Re: Problème wget avec debian 10 / Buster

J'ai installé CURL et avec ce lien ça ne fonctionne pas non plus!
https://files.phpmyadmin.net/phpMyAdmin … ges.tar.gz


Code:

root@debian:~# curl https://files.phpmyadmin.net/phpMyAdmin/4.9.4/phpMyAdmin-4.9.4-all-languages.tar.gz --output phpMyAdmin-4.9.4-all-languages.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:33 --:--:--     0^C
root@debian:~#

Le téléchargement ne démarre pas...


mais avec ce lien ça fonctionne:

Code:

root@debian:~# curl  https://portail.free.fr/content/uploads/cache/2019/02/shutterstock-229323511/2877045437.jpg --output 2877045437.jpg
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 31953  100 31953    0     0  72128      0 --:--:-- --:--:-- --:--:-- 72128
root@debian:~#

Last edited by Didier100 (20 Jan 2020 22:15:49)

Offline

 

#3 21 Jan 2020 08:19:55

claudep
Apôtre du libre
 
Registered: 19 May 2015
Posts: 67

Re: Problème wget avec debian 10 / Buster

wget possède une option -d pour afficher des informations de débogage. Ça vaut le coup d'essayer.

Offline

 

#4 21 Jan 2020 15:00:47

Didier100
Prêcheu(r|se) du libre
 
Registered: 11 Aug 2005
Posts: 136

Re: Problème wget avec debian 10 / Buster

Bonjour claudep,

Merci pour ton aide. ;-)

En fait je me suis arraché les cheveux pour trouver l'erreur.

La cause du problème se trouvait dans le fichier

Code:

/etc/network/interfaces

javait une mauvaise adresse de passerelle

Code:

gateway 192.168.1.1

au lieu de

Code:

gateway 192.168.1.254

J'ai une Freebox Crystal qui se configure à distance sur via site web de chez Free .... et le gateway est imposé par eux.

Ce qui est bizarre c'est que j'étais quand même capable à rejoindre certains sites web avec une fausse adresse de passerelle?

C'est en contrôlent toutes les config de réseau que je me suis aperçu de mon erreur.

Last edited by Didier100 (21 Jan 2020 15:03:42)

Offline

 
  • Index
  •  » Debian
  •  » Problème wget avec debian 10 / Buster

Board footer

Powered by FluxBB