Swisslinux.org

− The GNU/Linux crossroads in Switzerland −

 

Language

 

The Forum

You are not logged in.

#1 16 Jul 2019 16:08:10

Celem
Affranchi(e)
 
Registered: 16 Jul 2019
Posts: 4

Ecran noir sous Debian Buster

Bonjour,

Debianiste depuis toujours, j'utilise les différentes versions de Debian avec bonheur depuis de nombreuses années.

Mais je suis tombé sur un os avec la 10ème et dernière en date, Buster.

C'est à dire que j'ai un bel écran noir au démarrage, ceci autant bien avec la distribution live, qu'en installant. Il semble que la configuration de mon (vieil) écran (Dell 22'') ne soit pas correctement reconnue (Wayland en cause ?). Un message apparaît provenant de l'écran me suggérant d'utiliser cette configuration 1920x1080@60. Si je retente l'aventure je le prendrais en photo.

Retour donc sous Stretch (stable), où tout fonctionne bien.

Voici xrandr :

Screen 0: minimum 320 x 200, current 1152 x 864, maximum 16384 x 16384
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1152x864+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00 +
   1280x1024     75.02    60.02 
   1152x864      75.00*
   1024x768      75.03    60.00 
   800x600       75.00    60.32 
   640x480       75.00    59.94 
   720x400       70.08

et lspci :

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation H77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks PRO [Radeon HD 7570]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series]
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)

J'imagine que je dois passer un paramètre au boot, j'ai utilisé une clef usb d'installlation par le net. Mais comment le faire ? Ou bien s'agit-il d'autre chose ?

J'ai fait quelques recherches sans rien trouver sur Internet.

Merci d'avance.

Celem

Offline

 

#2 16 Jul 2019 17:19:07

Eggman
Admin
From: Grand-Lancy(GE)
Registered: 17 Nov 2004
Posts: 1021
Website

Re: Ecran noir sous Debian Buster

Salut,

As-tu essayé une version live avec un bureau alternatif, genre xfce ?
Ceux-là tournent avec X11 et non wayland, si je ne me trompe.
Ce serait une façon simple de vérifier si c'est bien wayland le soucis.


"It always takes longer than you expect, even when you take into account Hofstadter's Law."
Douglas Hofstadter, Gödel, Escher, Bach: An Eternal Golden Braid

Offline

 

#3 16 Jul 2019 19:07:50

Celem
Affranchi(e)
 
Registered: 16 Jul 2019
Posts: 4

Re: Ecran noir sous Debian Buster

Oui, effectivement, j'utilise xfce habituellement.

J'ai tout d'abord fait une installation avec xfce. Puis, j'ai essayé avec un live GNOME. Même échec.

Offline

 

#4 16 Jul 2019 20:27:52

Eggman
Admin
From: Grand-Lancy(GE)
Registered: 17 Nov 2004
Posts: 1021
Website

Re: Ecran noir sous Debian Buster

OK

Dans ce cas, si le problème est présent avec xfce également, je ne suis pas sûr que wayland soit le soucis et plus probablement s'agit-il d'un problème de détection de l'écran.

Dans ce cas, je ferais deux choses, démarrer en mode verbeux, pour voir ce qui se passe au démarrage, et vérifier les logs.

Pour passer grub en mode verbeux, il faut interrompre le démarrage, choisir "Advanced options ..." passer en mode édition, remplacer "quiet splash", par "verbose nosplash" et booter avec ces paramètres.

Ensuite accéder à un terminal, via CTRL+ALT+F1 (ou F2, F3, jusqu'à F6) s'identifier et taper la commande suivante en root:

Code:

dmesg

Cela permet de voir les messages d'erreur(entre autres) renvoyés par le noyau.

Éventuellement aussi, il faudrait consulter le fichier de log de X11 pour y trouver les messages d'erreur en tapant :

Code:

less /var/log/Xorg.0.log

"It always takes longer than you expect, even when you take into account Hofstadter's Law."
Douglas Hofstadter, Gödel, Escher, Bach: An Eternal Golden Braid

Offline

 

#5 16 Jul 2019 21:08:36

Celem
Affranchi(e)
 
Registered: 16 Jul 2019
Posts: 4

Re: Ecran noir sous Debian Buster

Merci, à force de manipulations j'ai pu obtenir ce message :

"failed to load rtl_nic/rtl18168e-3"

C'est un fichier du paquet realtek-firmware.

Depuis je me bat pour l'installer sur le support live et pour le faire reconnaître. J'ai essayé en y ajoutant le deb, sans succès, puis uniquement le fichier rtl18168e-3, dans le répertoire firmware puis à la base de la clef usb. Il n'est toujours pas chargé.

J'ai également mis les firmware habituels (https://cdimage.debian.org/debian-cd/cu … 64/iso-cd/) dans lesquels il n'est pas. Quelque chose m'échappe.

Pour ce soir j'abandonne. je m'y remets prochainement.

Merci pour l'aide.

Offline

 

#6 16 Jul 2019 21:45:18

Eggman
Admin
From: Grand-Lancy(GE)
Registered: 17 Nov 2004
Posts: 1021
Website

Re: Ecran noir sous Debian Buster

Je vois le soucis.

Pour le chipset realtek, il te faut les firmwares qui sont non-libres(non-free) et non inclus dans les images ISO officielles, mais qui sont inclus dans les images inofficielles debian.

Si tu trouve ça bizarre, c'est normal. On pourrait en discuter ici, mais ça prendrait des plombes !

Bref, choisis tes images ici:
https://cdimage.debian.org/cdimage/unof … -firmware/

Je te laisse le soin de regarder ce qui te convient. Il y a des images d'installation current, soit Buster, et des images current-live, soit des LiveCD installables Buster, avec les bureaux au choix, le tout pour diverses architectures et avec les firmwares (non-free) dont tout le monde ou presque à besoin.


"It always takes longer than you expect, even when you take into account Hofstadter's Law."
Douglas Hofstadter, Gödel, Escher, Bach: An Eternal Golden Braid

Offline

 

#7 17 Jul 2019 11:52:58

Celem
Affranchi(e)
 
Registered: 16 Jul 2019
Posts: 4

Re: Ecran noir sous Debian Buster

Excellent ! J'avais toujours snobé les images inofficielles. Je n'y aurai pas pensé.

La version live avec xfce fonctionne !

Je l'installerai, probablement ce week-end, après avoir fait les sauvegardes indispensables. Pour moi, je considère que le problème est résolu.

Merci beaucoup pour votre rapidité et votre intelligence.

Meilleures salutations.

Cehel

Offline

 

Board footer

Powered by FluxBB