Swisslinux.org

− The GNU/Linux crossroads in Switzerland −

 

Language

 

The Forum

You are not logged in.

  • Index
  •  » Debian
  •  » VaudTax 2018, impossible de lancer le programme

#1 11 Feb 2019 16:48:03

lucbrochard
Affranchi(e)
 
Registered: 03 Jan 2017
Posts: 5

VaudTax 2018, impossible de lancer le programme

Bonjour
J'utilise VaudTax sur Unbutu 16.04 depuis plusieurs année. Cette année, j'ai installé VaudTav 18, j'ai vérifié les Prérequis
Java 8 minimum (openjdk-8-jre) et webkit (libwebkitgtk-1.0-0) qui normalement son OK. J'ai recompressé le fichier, mais au moment de lancer le programme, il ne ce passe rien.
avez-vous des pistes pour résoudre ce problème avant le 15 mars ;-)
Merci

Offline

 

#2 11 Feb 2019 21:31:44

claudep
Apôtre du libre
 
Registered: 19 May 2015
Posts: 51

Re: VaudTax 2018, impossible de lancer le programme

cf. https://swisslinux.org/wiki/fr/document … _et_ubuntu

Voir la section "Lancement depuis le terminal", qui est la meilleure méthode pour voir apparaître les erreurs et ainsi donner des infos aux dépanneurs potentiels.

Offline

 

#3 18 Feb 2019 10:25:59

lucbrochard
Affranchi(e)
 
Registered: 03 Jan 2017
Posts: 5

Re: VaudTax 2018, impossible de lancer le programme

La fonction Lancer dans un terminal ne produit également aucun effet

Offline

 

#4 18 Feb 2019 10:36:41

lucbrochard
Affranchi(e)
 
Registered: 03 Jan 2017
Posts: 5

Re: VaudTax 2018, impossible de lancer le programme

Par contre si je sélectionne "afficher" au lieu de lancer j'ai cette fenêtre qui apparaît avec ce contenu :

# This script starts the application on Linux (like .exe in windows)

#!/bin/bash
# Unset OS Java-Paths
unset JAVA_HOME
unset JDK_HOME

JAVA_NOT_FOUND_MSG="Aucun interpréteur Java n'a pu être trouvé sur la ligne de commande.
Merci d'installer Java à l'aide du gestionnaire de paquet de votre distribution,
ou sur http://www.java.com/fr/download"

classpath='lib/dvbern-lib-update.jar:lib/cryptutil.jar'

if [ ! -f ///$classpath ] ; then
    cd `dirname $0`
else
    cd //
fi

type java &> /dev/null
if [ "$?" -ne "0" ] ; then
        echo $JAVA_NOT_FOUND_MSG
        which zenity &> /dev/null && zenity --no-wrap --no-markup --warning --window-icon=error --text="$JAVA_NOT_FOUND_MSG"
        exit 1
fi

libWebKitFile="/usr/lib/x86_64-linux-gnu/libwebkitgtk-1.0.so.0"

if [ ! -f "${libWebKitFile}" ] ; then
        echo "LibWebKitGtk-1.0 Does not exist. Add it."

        MY_LIBPATH="$(pwd)/lib/ubuntu/usr/lib/x86_64-linux-gnu"
        export LD_LIBRARY_PATH="${MY_LIBPATH}"
        echo "The libwebkitgtk library path is $LD_LIBRARY_PATH"
        ls $MY_LIBPATH

        echo "If it is still not working, try: sudo apt-get install libwebkitgtk-1.0-0"
fi


jre/bin/java -cp $classpath ch.dvbern.lib.update.Launcher

est-ce que ça veux dire que je doit réinstaller Java ?
si oui pouvez-vous m'expliquer pourquoi je ne e trouve pas dans les logiciels a télécharger ?

merci .

Offline

 

#5 20 Feb 2019 16:41:25

Maëlle Vogel
Affranchi(e)
 
Registered: 06 Feb 2019
Posts: 6

Re: VaudTax 2018, impossible de lancer le programme

Bonjour,
Les paquets ont souvent des mises jours et ces dernières ne se font pas toujours automatiquement. Je vous conseille de lancer la mise à jour de paquet java manuellement. Pour cela ouvrez un terminal et tapez sudo apt instal openjdk-8-jre
Ensuite votre mot de passe est demandé, il ne s'affichera pas donc il faut le taper à l'aveugle. Si des mises à jour sont disponibles vous devrez valider que vous voulez bien les installer.
J'espère que cela résoudra votre problème.

Offline

 

#6 25 Feb 2019 15:37:43

lucbrochard
Affranchi(e)
 
Registered: 03 Jan 2017
Posts: 5

Re: VaudTax 2018, impossible de lancer le programme

Merci pour cette information. J'ai déjà réalisé cette mise a jour ainsi que pour : libwebkitgtk-1.0-0. mais ce ne fonctionne toujours pas.

Offline

 

#7 26 Feb 2019 21:49:20

DVZ15
Affranchi(e)
 
Registered: 28 Jan 2018
Posts: 4

Re: VaudTax 2018, impossible de lancer le programme

J'ai installé java 8  via ppa et ça fonctionne!

sudo add-apt-repository ppa:webupd8team/java
sudo apt update
sudo apt-get install oracle-java8-installer

Plus de détail ici : -> http://ubuntuhandbook.org/index.php/201 … ntu-18-04/

Last edited by DVZ15 (26 Feb 2019 21:51:14)

Offline

 
  • Index
  •  » Debian
  •  » VaudTax 2018, impossible de lancer le programme

Board footer

Powered by FluxBB