Swisslinux.org

− Le carrefour GNU/Linux en Suisse −

Bienvenue invité
 

Langue

 

Le Forum

Vous n'êtes pas identifié.

#1 02 Aug 2018 20:24:09

joachim
Affranchi(e)
 
Date d'inscription: 02 Aug 2018
Messages: 5

Pas d'image sur l'écran built-in du laptop

J'ai l'année passée installé Ubuntu Gnome 17.04 sur mon portable N240BU-PRO. Jusque là tout fonctionnait, mais aux alentours de novembre 2017, lors du démarrage du PC, l'écran affichant normalement le logo Why (BIOS splash screen) reste noir, puis peu après l'écran de boot de Linux apparaît. En esssayant de connecter un deuxième écran, j'ai pu constater que le Logo Why apparaissait sur celui-ci.
J'ai continuer d'utiliser l'ordinateur comme cela, espérant qu'une mise à jour résolve ce problème, mais rien n'a changé.

J'ai alors dernièrement essayé de ré-installer Ubuntu 16.04, version sur laquelle l'écran ne posait pas de problème.
Mais depuis l'installation, même l'OS ne peut pas être visualisé sur l'écran du portable.En allant dans les paramètres d'écrans de Ubuntu, uniquement l'écran HDMI est visible.

Code:

$ xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200     59.95*+
   1920x1080     60.00    50.00    50.00    50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1600x1200     60.00  
   1280x1024     75.02    60.02  
   1440x900      74.98    59.90  
   1280x800      74.93    59.91  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x576i      50.00  
   720x480       60.00    59.94  
   720x480i      60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08

Merci de votre aide!

Dernière modification par joachim (06 Aug 2018 17:46:53)

Hors ligne

 

#2 02 Aug 2018 22:39:32

François Marthaler
Modérateur
Lieu: Prilly
Date d'inscription: 07 Sep 2013
Messages: 1499
Site web

Re: Pas d'image sur l'écran built-in du laptop

Bonsoir,

Nos machines sont configurées de telle sorte que seules les version LTS (long term support) sont proposées et pas les versions intermédiaire qui ne sont maintenues que durant 6 mois, jusqu'à la sortie de la version intermédiaire suivante.

Ubuntu 17.04 n'est plus supportée depuis la sortie de la version 17.10, en octobre 2017. Ceci vaut aussi pour le système de migration vers la version suivante. Ainsi, la mise à niveau vers Ubuntu 17.10 n'est plus maintenue. Pour corser le tout, il en va de même pour la 17.10, depuis la publication de la 18.04 en avril 2018.

J'espère que cette solution pourra vous tirer d'affaire: https://swisslinux.org/forum/viewtopic. … 43#p26743.

Cordialement.


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Hors ligne

 

#3 03 Aug 2018 10:56:33

joachim
Affranchi(e)
 
Date d'inscription: 02 Aug 2018
Messages: 5

Re: Pas d'image sur l'écran built-in du laptop

Bonjour,

merci pour votre lien, mais le problème n'est pas le même.

J'ai actuellement pu ré-installer Ubuntu 16.04 en passant par une clé bootable (le tout sur un écran branché en HDMI), mais l'écran du portable ne s'allume toujours pas (soit quand je débranche l'écran HDMI avant de démarrer l'ordinateur, soit quand je le débranche après).

Ce qui est étrange c'est que même l'écran de démarrage avec le logo Why avant même de lancer l'OS ne s'affiche pas sur l'écran du laptop. Je ne comprends pas comment l'OS peut affecter cela.
Pour ce qui est du fonctionnement Hardware de l'écran, je suis sûr qu'il est fonctionnel, car il y a 1 semaine (avant que j'installe Ubuntu 16.04), il fonctionnait encore (sauf qu'il n'affichait pas l'écran de démarrage avec le logo Why).

Merci encore de votre aide


EDIT 1:

Voici ce que j'ai testé pour le moment:

- Activer l'écran DP-1 manuellement avec la commande

Code:

$ xrandr --output DP-1 --auto

- Controller que tous les firmwares du driver intel du chipset graphique i915 soient présents:

Code:

$ ls /lib/firmware/i915/ | grep kbl
kbl_dmc_ver1_01.bin
kbl_dmc_ver1.bin
kbl_guc_ver9_14.bin
kbl_huc_ver02_00_1810.bin

- Reset du BIOS en enlevant la pile du BIOS

- Enlever mes disques SSD et rebooter

Toujours pas d'image sur l'écran built-in du laptop.

Dernière modification par joachim (06 Aug 2018 17:41:40)

Hors ligne

 

#4 07 Aug 2018 10:14:29

Maude Issolah
Modérateur
 
Date d'inscription: 01 Feb 2018
Messages: 76

Re: Pas d'image sur l'écran built-in du laptop

Bonjour,
Si l'écran du laptop ne s'allume pas, mais que vous avez une image normale sur un écran externe, il s'agit probablement d'un problème matériel au niveau de l'écran en lui-même ou du câble qui le relie à la carte mère.
Vous pouvez nous rapporter/envoyer votre ordinateur pour réparation. Si vous l'envoyez, merci d'ajouter un mot qui décrit le problème.

why! open computing SA
Rte de Renens 4
CH-1008 Prilly


Je travaille chez Why!

Hors ligne

 

#5 07 Aug 2018 11:01:31

joachim
Affranchi(e)
 
Date d'inscription: 02 Aug 2018
Messages: 5

Re: Pas d'image sur l'écran built-in du laptop

Bonjour,

Merci de votre réponse

C'est en effet les symptômes, mais ça me paraît très peu plausible car l'écran du laptop fonctionnait parfaitement la semaine passée avant que je fasse la re-installation de Ubuntu 16.04 (sauf bien sûr que je ne pouvais pas voir le BIOS splash screen). Je ne crois pas que l'installation de l'OS ait pu affecter le hardware.

Je pense que je vais passer dans vos bureaux si je ne trouves toujours pas de solution (j'ai également écrit sur d'autres forums sans avoir de solution).

Hors ligne

 

#6 09 Aug 2018 15:11:10

joachim
Affranchi(e)
 
Date d'inscription: 02 Aug 2018
Messages: 5

Re: Pas d'image sur l'écran built-in du laptop

Problème partiellement résolu!

J'ai activé l'option "UEFI boot mode" dans les paramètres du firmware (avant je bootais en BIOS mode).
Lorsque j'ai relancé l'installation sur ma clé bootable, elle a démarré sur l'écran built-in du portable! J'ai finalisé l'installation et redémarré, et l'OS démarre maintenant sur mon écran.

Je ne vois par contre toujours pas le splash screen du firmware (avec le logo Why!) sur l'écran du laptop. Je suis obligé de connecter un écran HDMI pour accéder aux paramètres par exemple.

Est-ce possible que Linux ait modifié des paramètres du firmware qui ne sont pas visibles dans les options graphiques? Ou est-ce potentiellement le firmware qui est problématique?

Merci de votre aide

Dernière modification par joachim (09 Aug 2018 15:27:22)

Hors ligne

 

#7 10 Aug 2018 12:48:24

Maude Issolah
Modérateur
 
Date d'inscription: 01 Feb 2018
Messages: 76

Re: Pas d'image sur l'écran built-in du laptop

Bonjour,
Voici ce que j'ai trouvé pour le moment:
https://bugs.launchpad.net/ubuntu/+sour … ug/1734147
http://dailylinuxuser.com/2018/01/how-t … aptop.html un tuto plus clair que ce que l'on trouve sur lauchpad

Apparemment le système peut corrompre le bios...

Vous pourriez essayer d'installer Ubuntu 18.04 qui a un noyau plus récent.
Ou aussi supprimer le fichier .config/monitors.xml de votre dossier personnel (après l'avoir sauvegardé au cas ou).


Je travaille chez Why!

Hors ligne

 

#8 10 Aug 2018 14:39:59

joachim
Affranchi(e)
 
Date d'inscription: 02 Aug 2018
Messages: 5

Re: Pas d'image sur l'écran built-in du laptop

Bonjour,

Merci pour les liens. Je suis actuellement sur Ubuntu 18.04 (kernel version 4.15.0-30-generic), est-ce que je dois quand même essayer d'installer les kernels proposés?

J'ai tenté de supprimer le fichier monitor.xml sans succès

Hors ligne

 

Pied de page des forums

Powered by FluxBB