Swisslinux.org

− Le carrefour GNU/Linux en Suisse −

Bienvenue invité
 

Langue

 

Le Forum

Vous n'êtes pas identifié.

#1 13 Feb 2017 12:51:06

gdeneyer
Citoyen(ne)
 
Date d'inscription: 08 Jun 2016
Messages: 24

Connexion au projecteur ne fonctionne PLUS

Helllo,

Jusqu'à vendredi passé, j'utilisais sans aucun soucis mon projecteur EPSON EB-X9 pour mes cours. Quelqu'un me l'a ensuite emprunté pour brancher sa XBox et, depuis, plus moyen de m'y connecter.

Observations :
- le projecteur s'allume et se connecte parfaitement à l'ordi de ma copine, sous Ubuntu 16.04 (même version que moi)
- lorsque je branche le câble VGA chez moi, rien ne se passe (ni au niveau du projecteur/ni au niveau de l'ordi)
- lorsque je démarre avec le cable branché, j'ai le message Why Open Computing qui s'affiche sur l'écran et sur le projecteur puis, à nouveau, plus rien sur le projecteur.
- lorsque je tape xrandr, j'obtiens : "xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 174mm
   1920x1080     60.02*+  59.93 
   1680x1050     59.95    59.88 
   1600x1024     60.17 
   1400x1050     59.98 
   1600x900      60.00 
   1280x1024     60.02 
   1440x900      59.89 
   1280x960      60.00 
   1368x768      60.00 
   1360x768      59.80    59.96 
   1152x864      60.00 
   1280x720      60.00 
   1024x768      60.00 
   1024x576      60.00 
   960x540       60.00 
   800x600       60.32    56.25 
   864x486       60.00 
   640x480       59.94 
   720x405       60.00 
   640x360       60.00 
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)"

Manipulations déjà effectuées (oui, j'ai déjà cherché sur le net)
- redémarrer (l'ordi comme le projo, plusieurs fois)
- adaptateur HDMI : dans ce cas, l'image apparaît sur le projo puis s'arrête, puis réapparaît, comme s'il y avait un faux contact
- essai avec plusieurs câble (pas en cause vu que ça fonctionne avec l'ordi de ma copine)


L'ordi n'a pas été utilisé entre vendredi (quand le projecteur marchait) et maintenant (quand il ne marche plus), par contre le projecteur a été utilisé. J'en déduis que, peut-être, le fait de brancher la Xbox aurait déréglé qqch dans la config du projecteur OU c'est juste un malheureux hasard et Ubuntu me cache quelque chose.

Merci d'avance pour votre aide,
Gilles

Hors ligne

 

#2 13 Feb 2017 13:01:00

gdeneyer
Citoyen(ne)
 
Date d'inscription: 08 Jun 2016
Messages: 24

Re: Connexion au projecteur ne fonctionne PLUS

Autre information importante : lorsque je branche un écran externe normal (pas un projo), cela marche très bien et xrandr m'affiche :
DP1 connected 1280x1024+1920+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024     60.02*+  75.02 
   1152x864      75.00 
   1024x768      75.08    70.07    60.00    60.00 
   832x624       74.55 
   800x600       72.19    75.00    60.32    56.25 
   640x480       75.00    72.81    66.67    60.00 
   720x400       70.08

Hors ligne

 

#3 15 Feb 2017 12:55:08

gdeneyer
Citoyen(ne)
 
Date d'inscription: 08 Jun 2016
Messages: 24

Re: Connexion au projecteur ne fonctionne PLUS

Voilà une manip qui me permet d'afficher quand même :

xrandr --addmode DP1 1024x768
xrandr --output DP1 --pos 0x0 --mode 1024x768 --rate 60.00

Le soucis est double :
- je dois à chaque fois refaire la manip: ajouter un mode et "forcer la connexion" alors qu'avant le projecteur était reconnu et il suffisait d'utiliser Fn+F7 pour que l'écran soit configuré correctement (Double écran ou écran étendu)
- je ne parviens pas à me mettre en mode écran étendu : j'ai bien essayé la commande
                    xrandr --output DP1 --pos 1920x0 --mode 1024x768 --rate 60.00
  vu que mon écran est en 1920x1080, ça place bien un écran à droite mais cela 'bugge" : ça me fait un écran noir et je peux y glisser des fenêtres actives mais cela part en sucette dès que je déplace la fenêtre (comme quand une carte graphique est cassée).

Voilà, si quelqu'un a une idée miracle pour revenir à ma situation de départ, je suis preneur. En attendant, je bricole...

Hors ligne

 

#4 17 Feb 2017 11:35:13

antoine.why
Modérateur
 
Date d'inscription: 30 Jul 2013
Messages: 90

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour,

Pouvez-vous nous indiquer quel modèle d'ordinateur vous avez? W253EU? W650SZ?
Savez-vous comment la Xbox a été branchée ? par VGA HDMI?

Merci pour ces informations qui vont nous aider à cerner le problème avec une machine de test équivalente à la vôtre.

Hors ligne

 

#5 17 Feb 2017 12:02:05

gdeneyer
Citoyen(ne)
 
Date d'inscription: 08 Jun 2016
Messages: 24

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour,

Ma machine est le Ultra portable - N240JU Pro

La XBOX a été branchée par HDMI

Merci pour votre aide,
Cordialement,
Gilles

Hors ligne

 

#6 17 Feb 2017 18:03:12

antoine.why
Modérateur
 
Date d'inscription: 30 Jul 2013
Messages: 90

Re: Connexion au projecteur ne fonctionne PLUS

Bonsoir,

En utilisant un écran externe connecté par HDMI à un N240JU-Pro j'ai constaté les faits suivants:

En pressant les touches Fn + F7 plusieurs fois j'ai passé de :

Ecrans en mode étendu à
Ecran clonés à
Ecran externe seul à
Ecran portable seul puis à nouveau
Ecrans en mode étendu

Juste une constatation encore notre projecteur à plusieurs prises VGA qu'en est-il du vôtre?

J'espère que ces constatations vont vous aider.

Hors ligne

 

#7 18 Feb 2017 17:28:09

gdeneyer
Citoyen(ne)
 
Date d'inscription: 08 Jun 2016
Messages: 24

Re: Connexion au projecteur ne fonctionne PLUS

Bonsoir,

Malheureusement ça ne m'aide pas.

Comme je l'ai précisé dans mon message précédent, je pouvais également utiliser la touche Fn + F7 plusieurs fois pour arriver sur le mode désiré. L'objet de mon poste est de revenir à cette situation, justement. Ici, le projo n'est pas détecté et les touches Fn + F7 n'ont aucun effet.

Effectivement, mon projecteur a deux ports VGA, un pour l'ordinateur à relier au projecteur et l'autre pour brancher un écran externe au projecteur (exemple : si l'on branche une tour au projo et puis un câble du projo vers un écran.

J'ai été complet dans mes questions et les démarches effectuées. Le problème est sans aucun doute Software mais mon espoir était qu'un féru d'Ubuntu sache comment je pourrais identifier le problème exact.

Bien cordialement,
Gilles

Hors ligne

 

#8 20 Feb 2017 10:29:32

antoine.why
Modérateur
 
Date d'inscription: 30 Jul 2013
Messages: 90

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour,

Je suis désolé que le problème persiste.

Dans mon précédent post il manque une partie importante :

En utilisant un écran externe connecté par HDMI puis un projecteur par VGA à un N240JU-Pro j'ai constaté les faits suivants:

En pressant les touches Fn + F7 plusieurs fois j'ai passé de :

Ecrans en mode étendu à
Ecran clonés à
Ecran externe seul à
Ecran portable seul puis à nouveau
Ecrans en mode étendu

D'oû ma question
Juste une constatation encore notre projecteur à plusieurs prises VGA qu'en est-il du vôtre?

De plus vous avez mentionné vous même que vous aviez déjà testé avec un écran externe je vous cite:

Autre information importante : lorsque je branche un écran externe normal (pas un projo), cela marche très bien et xrandr m'affiche :

DP1 connected 1280x1024+1920+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024     60.02*+  75.02 
   1152x864      75.00 
   1024x768      75.08    70.07    60.00    60.00 
   832x624       74.55 
   800x600       72.19    75.00    60.32    56.25 
   640x480       75.00    72.81    66.67    60.00 
   720x400       70.08



Selon moi il faut donc chercher du côté des réglages de votre projecteur, car la prise VGA est hors de cause puisque cela fonctionne avec un écran externe ou n'avez-vous pas connecté l'écran externe à l'aide du port VGA comme le laisse supposer le résultat de votre commande xrandr?

DP1 connected 1280x1024+1920+0 (normal left inverted right x axis y axis) 338mm x 270mm

En espérant que cette fois-ci  mes investigations puissent vous aider
Cordialement
Antoine

Hors ligne

 

#9 23 Feb 2017 13:36:30

Patrice
Affranchi(e)
 
Date d'inscription: 14 Jan 2017
Messages: 5

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour.
J'ai le même problème avec un N240JU : la sortie VGA ne détecte pas certains vidéo-projecteurs. Notez qu'un autre PC (HP) avec ubuntu 14.04 détecte tous ces projecteurs automatiquement.

J'ai contourné le problème en faisant un petit utilitaire en python lançant des commandes xrandr, qui force la sortie VGA sur un mode donné mais ça ne fonctionne pas très bien. Et comme Gilles, en mettant les écrans côte à côte ça fonctionne extrêmement mal : écran à fond noir avec les fenêtres qui font des traînées en les déplaçant.

J'en viens à me demander si ces cartes vidéos n'ont pas un problème de compatibilité avec certains projecteurs.
Merci.
Patrice.

Hors ligne

 

#10 23 Feb 2017 15:30:12

gdeneyer
Citoyen(ne)
 
Date d'inscription: 08 Jun 2016
Messages: 24

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour Antoine, Patrice,

@Antoine : si,  c'est bien via le port VGA que j'ai branché l'écran externe, qui fonctionnait. Je ne sais pas pourquoi xrandr affiche ce port comme DP1 et pas VGA mais c'est bien de celui-là qu'il s'agit.

@Patrice : c'est effectivement exactement le même problème. Ecran étendu via xrandr me donne un écran noir + traînée derrière les fenêtres.

Je ne l'ai pas précisé mais j'ai également regardé du côté du projecteur en réinitialisant les paramètres de celui-ci. Pour moile problèmene peut être identifié comme venant du projecteur ou d'Ubuntu à partir des informations vu que :
- Mon projecteur est bien détecté sur l'ordinateur de ma copîne (ubuntu 16.04 également, ASUS), donc il fonctionne
- L'ordinateur détecte certains écrans via le VGA, donc le port VGA fonctionne.

Bien cordialement,
Gilles De Neyer

Hors ligne

 

#11 Hier 08:00:14

jean@adimp.ch
Illuminé(e)
Lieu: Marly
Date d'inscription: 10 Mar 2005
Messages: 809
Site web

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour,
Peut-être le projecteur nécessite une mise à jour du firmware. Est-ce que vous pouvez regarder?
Meilleures salutations.


--------------------------------------------------------
Jean Tinguely Awais
Ma vie sur twitter : http://www.twitter.com/tservi
Looking for THE job of my life : see http://www.t-servi.com

Hors ligne

 

Pied de page des forums

Powered by FluxBB