Swisslinux.org

− Le carrefour GNU/Linux en Suisse −

Bienvenue invité
 

Langue

 

Le Forum

Vous n'êtes pas identifié.

#1 13 Feb 2017 12:51:06

gdeneyer
Humain(e) libre
 
Date d'inscription: 08 Jun 2016
Messages: 31

Connexion au projecteur ne fonctionne PLUS

Helllo,

Jusqu'à vendredi passé, j'utilisais sans aucun soucis mon projecteur EPSON EB-X9 pour mes cours. Quelqu'un me l'a ensuite emprunté pour brancher sa XBox et, depuis, plus moyen de m'y connecter.

Observations :
- le projecteur s'allume et se connecte parfaitement à l'ordi de ma copine, sous Ubuntu 16.04 (même version que moi)
- lorsque je branche le câble VGA chez moi, rien ne se passe (ni au niveau du projecteur/ni au niveau de l'ordi)
- lorsque je démarre avec le cable branché, j'ai le message Why Open Computing qui s'affiche sur l'écran et sur le projecteur puis, à nouveau, plus rien sur le projecteur.
- lorsque je tape xrandr, j'obtiens : "xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 174mm
   1920x1080     60.02*+  59.93 
   1680x1050     59.95    59.88 
   1600x1024     60.17 
   1400x1050     59.98 
   1600x900      60.00 
   1280x1024     60.02 
   1440x900      59.89 
   1280x960      60.00 
   1368x768      60.00 
   1360x768      59.80    59.96 
   1152x864      60.00 
   1280x720      60.00 
   1024x768      60.00 
   1024x576      60.00 
   960x540       60.00 
   800x600       60.32    56.25 
   864x486       60.00 
   640x480       59.94 
   720x405       60.00 
   640x360       60.00 
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)"

Manipulations déjà effectuées (oui, j'ai déjà cherché sur le net)
- redémarrer (l'ordi comme le projo, plusieurs fois)
- adaptateur HDMI : dans ce cas, l'image apparaît sur le projo puis s'arrête, puis réapparaît, comme s'il y avait un faux contact
- essai avec plusieurs câble (pas en cause vu que ça fonctionne avec l'ordi de ma copine)


L'ordi n'a pas été utilisé entre vendredi (quand le projecteur marchait) et maintenant (quand il ne marche plus), par contre le projecteur a été utilisé. J'en déduis que, peut-être, le fait de brancher la Xbox aurait déréglé qqch dans la config du projecteur OU c'est juste un malheureux hasard et Ubuntu me cache quelque chose.

Merci d'avance pour votre aide,
Gilles

Hors ligne

 

#2 13 Feb 2017 13:01:00

gdeneyer
Humain(e) libre
 
Date d'inscription: 08 Jun 2016
Messages: 31

Re: Connexion au projecteur ne fonctionne PLUS

Autre information importante : lorsque je branche un écran externe normal (pas un projo), cela marche très bien et xrandr m'affiche :
DP1 connected 1280x1024+1920+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024     60.02*+  75.02 
   1152x864      75.00 
   1024x768      75.08    70.07    60.00    60.00 
   832x624       74.55 
   800x600       72.19    75.00    60.32    56.25 
   640x480       75.00    72.81    66.67    60.00 
   720x400       70.08

Hors ligne

 

#3 15 Feb 2017 12:55:08

gdeneyer
Humain(e) libre
 
Date d'inscription: 08 Jun 2016
Messages: 31

Re: Connexion au projecteur ne fonctionne PLUS

Voilà une manip qui me permet d'afficher quand même :

xrandr --addmode DP1 1024x768
xrandr --output DP1 --pos 0x0 --mode 1024x768 --rate 60.00

Le soucis est double :
- je dois à chaque fois refaire la manip: ajouter un mode et "forcer la connexion" alors qu'avant le projecteur était reconnu et il suffisait d'utiliser Fn+F7 pour que l'écran soit configuré correctement (Double écran ou écran étendu)
- je ne parviens pas à me mettre en mode écran étendu : j'ai bien essayé la commande
                    xrandr --output DP1 --pos 1920x0 --mode 1024x768 --rate 60.00
  vu que mon écran est en 1920x1080, ça place bien un écran à droite mais cela 'bugge" : ça me fait un écran noir et je peux y glisser des fenêtres actives mais cela part en sucette dès que je déplace la fenêtre (comme quand une carte graphique est cassée).

Voilà, si quelqu'un a une idée miracle pour revenir à ma situation de départ, je suis preneur. En attendant, je bricole...

Hors ligne

 

#4 17 Feb 2017 11:35:13

antoine.why
Modérateur
 
Date d'inscription: 30 Jul 2013
Messages: 101

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour,

Pouvez-vous nous indiquer quel modèle d'ordinateur vous avez? W253EU? W650SZ?
Savez-vous comment la Xbox a été branchée ? par VGA HDMI?

Merci pour ces informations qui vont nous aider à cerner le problème avec une machine de test équivalente à la vôtre.

Hors ligne

 

#5 17 Feb 2017 12:02:05

gdeneyer
Humain(e) libre
 
Date d'inscription: 08 Jun 2016
Messages: 31

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour,

Ma machine est le Ultra portable - N240JU Pro

La XBOX a été branchée par HDMI

Merci pour votre aide,
Cordialement,
Gilles

Hors ligne

 

#6 17 Feb 2017 18:03:12

antoine.why
Modérateur
 
Date d'inscription: 30 Jul 2013
Messages: 101

Re: Connexion au projecteur ne fonctionne PLUS

Bonsoir,

En utilisant un écran externe connecté par HDMI à un N240JU-Pro j'ai constaté les faits suivants:

En pressant les touches Fn + F7 plusieurs fois j'ai passé de :

Ecrans en mode étendu à
Ecran clonés à
Ecran externe seul à
Ecran portable seul puis à nouveau
Ecrans en mode étendu

Juste une constatation encore notre projecteur à plusieurs prises VGA qu'en est-il du vôtre?

J'espère que ces constatations vont vous aider.

Hors ligne

 

#7 18 Feb 2017 17:28:09

gdeneyer
Humain(e) libre
 
Date d'inscription: 08 Jun 2016
Messages: 31

Re: Connexion au projecteur ne fonctionne PLUS

Bonsoir,

Malheureusement ça ne m'aide pas.

Comme je l'ai précisé dans mon message précédent, je pouvais également utiliser la touche Fn + F7 plusieurs fois pour arriver sur le mode désiré. L'objet de mon poste est de revenir à cette situation, justement. Ici, le projo n'est pas détecté et les touches Fn + F7 n'ont aucun effet.

Effectivement, mon projecteur a deux ports VGA, un pour l'ordinateur à relier au projecteur et l'autre pour brancher un écran externe au projecteur (exemple : si l'on branche une tour au projo et puis un câble du projo vers un écran.

J'ai été complet dans mes questions et les démarches effectuées. Le problème est sans aucun doute Software mais mon espoir était qu'un féru d'Ubuntu sache comment je pourrais identifier le problème exact.

Bien cordialement,
Gilles

Hors ligne

 

#8 20 Feb 2017 10:29:32

antoine.why
Modérateur
 
Date d'inscription: 30 Jul 2013
Messages: 101

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour,

Je suis désolé que le problème persiste.

Dans mon précédent post il manque une partie importante :

En utilisant un écran externe connecté par HDMI puis un projecteur par VGA à un N240JU-Pro j'ai constaté les faits suivants:

En pressant les touches Fn + F7 plusieurs fois j'ai passé de :

Ecrans en mode étendu à
Ecran clonés à
Ecran externe seul à
Ecran portable seul puis à nouveau
Ecrans en mode étendu

D'oû ma question
Juste une constatation encore notre projecteur à plusieurs prises VGA qu'en est-il du vôtre?

De plus vous avez mentionné vous même que vous aviez déjà testé avec un écran externe je vous cite:

Autre information importante : lorsque je branche un écran externe normal (pas un projo), cela marche très bien et xrandr m'affiche :

DP1 connected 1280x1024+1920+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024     60.02*+  75.02 
   1152x864      75.00 
   1024x768      75.08    70.07    60.00    60.00 
   832x624       74.55 
   800x600       72.19    75.00    60.32    56.25 
   640x480       75.00    72.81    66.67    60.00 
   720x400       70.08



Selon moi il faut donc chercher du côté des réglages de votre projecteur, car la prise VGA est hors de cause puisque cela fonctionne avec un écran externe ou n'avez-vous pas connecté l'écran externe à l'aide du port VGA comme le laisse supposer le résultat de votre commande xrandr?

DP1 connected 1280x1024+1920+0 (normal left inverted right x axis y axis) 338mm x 270mm

En espérant que cette fois-ci  mes investigations puissent vous aider
Cordialement
Antoine

Hors ligne

 

#9 23 Feb 2017 13:36:30

Patrice
Affranchi(e)
 
Date d'inscription: 14 Jan 2017
Messages: 9

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour.
J'ai le même problème avec un N240JU : la sortie VGA ne détecte pas certains vidéo-projecteurs. Notez qu'un autre PC (HP) avec ubuntu 14.04 détecte tous ces projecteurs automatiquement.

J'ai contourné le problème en faisant un petit utilitaire en python lançant des commandes xrandr, qui force la sortie VGA sur un mode donné mais ça ne fonctionne pas très bien. Et comme Gilles, en mettant les écrans côte à côte ça fonctionne extrêmement mal : écran à fond noir avec les fenêtres qui font des traînées en les déplaçant.

J'en viens à me demander si ces cartes vidéos n'ont pas un problème de compatibilité avec certains projecteurs.
Merci.
Patrice.

Hors ligne

 

#10 23 Feb 2017 15:30:12

gdeneyer
Humain(e) libre
 
Date d'inscription: 08 Jun 2016
Messages: 31

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour Antoine, Patrice,

@Antoine : si,  c'est bien via le port VGA que j'ai branché l'écran externe, qui fonctionnait. Je ne sais pas pourquoi xrandr affiche ce port comme DP1 et pas VGA mais c'est bien de celui-là qu'il s'agit.

@Patrice : c'est effectivement exactement le même problème. Ecran étendu via xrandr me donne un écran noir + traînée derrière les fenêtres.

Je ne l'ai pas précisé mais j'ai également regardé du côté du projecteur en réinitialisant les paramètres de celui-ci. Pour moile problèmene peut être identifié comme venant du projecteur ou d'Ubuntu à partir des informations vu que :
- Mon projecteur est bien détecté sur l'ordinateur de ma copîne (ubuntu 16.04 également, ASUS), donc il fonctionne
- L'ordinateur détecte certains écrans via le VGA, donc le port VGA fonctionne.

Bien cordialement,
Gilles De Neyer

Hors ligne

 

#11 25 Feb 2017 08:00:14

jean@adimp.ch
Modérateur
Lieu: Marly
Date d'inscription: 10 Mar 2005
Messages: 877
Site web

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour,
Peut-être le projecteur nécessite une mise à jour du firmware. Est-ce que vous pouvez regarder?
Meilleures salutations.


--------------------------------------------------------
Jean Tinguely Awais
Ma vie sur twitter : http://www.twitter.com/tservi
Looking for THE job of my life : see http://www.t-servi.com

Hors ligne

 

#12 02 Mar 2017 18:10:27

Luc Wachter
Modérateur
 
Lieu: Prilly
Date d'inscription: 01 Sep 2016
Messages: 200
Site web

Re: Connexion au projecteur ne fonctionne PLUS

Bonsoir,

Avez-vous réussi à régler votre problème?

Si non, j'ai quelques propositions de test. Premièrement, avez-vous déjà essayé de brancher le projecteur à l'ordinateur avant de l'allumer? Il semble que cela permette de contourner un bug d'ubuntu.

Mon autre question porte sur les menus. Avez-vous déjà tenté de faire le réglage depuis le menu des préférences? Pour cela, allez dans paramètres système->Affichage. Il devrait y avoir ici votre écran principal, celui de votre ordinateur, et un second moniteur, le projecteur. Il est, en général, possible de l'activer ici et de changer les paramètres. Peut-être pourrez-vous régler le problème depuis là.

Pouvez-vous essayer ces solutions éventuelles?


why! N240BU-Pro | i7-7500U | 8Go

Hors ligne

 

#13 05 Mar 2017 16:08:12

gdeneyer
Humain(e) libre
 
Date d'inscription: 08 Jun 2016
Messages: 31

Re: Connexion au projecteur ne fonctionne PLUS

Hello,

J'avais déjà essayé de brancher le projecteur avant l'allumage de l'ordinateur : effectivement il reconnaît le projecteur (l'écran d'accueil Why apparaît) mais dès que c'est ubuntu qui se lance, plus rien. Cela ne contourne donc pas le problème.
J'avais bien sûr également essayé via les préférences ubuntu mais l'écran externe n'apparaît pas dans le menu affichage.

Nouveauté, j'ai maintenant le même problème avec mon écran externe Acer. Il s'agit donc bien d'un problème Software Ubuntu et pas du projecteur.

Bien cordialement,
Gilles

Hors ligne

 

#14 06 Mar 2017 13:12:53

Patrice
Affranchi(e)
 
Date d'inscription: 14 Jan 2017
Messages: 9

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour.
J'ai aussi démarré avec le projecteur branché et la page "Why sustainable coputers" apparaît sur le projecteur jusqu'à ce que Ubuntu démarre.
Dans l'ensemble je suis beaucoup plus embêté avec Ubuntu 16.04 qu'avec 14.04. Mais j'ai essayé sur ce PC: la version 14.04 n'a pas le driver pour la wifi.
Cordialement,
Patrice.

Hors ligne

 

#15 06 Mar 2017 23:43:14

Luc Wachter
Modérateur
 
Lieu: Prilly
Date d'inscription: 01 Sep 2016
Messages: 200
Site web

Re: Connexion au projecteur ne fonctionne PLUS

Bonsoir,

Merci de vos réponses à tous les deux.

@gdeneyer: Vous confirmez que votre écran Acer, avec lequel vous avez maintenant aussi des problèmes, était connecté en VGA?

Si oui, la prochaine étape, pour moi, est de faire le test avec un câble HDMI. Avez-vous la possibilité de tester ça? (Sur le moniteur, et le projecteur.)


why! N240BU-Pro | i7-7500U | 8Go

Hors ligne

 

#16 09 Mar 2017 05:44:12

gdeneyer
Humain(e) libre
 
Date d'inscription: 08 Jun 2016
Messages: 31

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour,

Oui je confirme mais, malheureusement pour la résolution du problème, avec l'écran VGA ça re fonctionne. Le problème ne concerne donc que le projecteur.
EDIT : ça ne refonctionne pas avec l'écran, espoir passager


Cordialement,
Gilles

Dernière modification par gdeneyer (09 Mar 2017 19:40:43)

Hors ligne

 

#17 09 Mar 2017 18:24:43

Luc Wachter
Modérateur
 
Lieu: Prilly
Date d'inscription: 01 Sep 2016
Messages: 200
Site web

Re: Connexion au projecteur ne fonctionne PLUS

Bonsoir,

C'est noté. Cela dit, tester avec HDMI sur le projecteur, ça n'est toujours pas stupide. Cela vous est-il possible ou le projecteur n'est-il pas équipé pour?

Merci.


why! N240BU-Pro | i7-7500U | 8Go

Hors ligne

 

#18 09 Mar 2017 19:43:56

gdeneyer
Humain(e) libre
 
Date d'inscription: 08 Jun 2016
Messages: 31

Re: Connexion au projecteur ne fonctionne PLUS

Le projecteur n'est pas équipé d'un port HDMI.

Par contre, j'ai un collègue qui n'a pas de port VGA et qui utilisait donc un adaptateur VGA --> HDMI pour se connecter.

J'avais fait le test de mettre le projecteur, via l'adaptateur, dans l'HDMI de mon ordinateur, le résultat fut le suivant :
l image apparaît sur l'écran 1 ou 2 secondes puis s'éteint puis revient puis s'éteint puis revient .... Clignotement, coupures, impossible d'avoir une image stable.

Nouvelle info : mon collègue qui utilise un ordinateur tournant avec Windows n'arrive plus non plus à avoir une bonne image via son adaptateur HDMI. Même clignotement.

Hors ligne

 

#19 14 Mar 2017 17:19:41

Patrice
Affranchi(e)
 
Date d'inscription: 14 Jan 2017
Messages: 9

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour.
J'ai fait l'essai en HDMI sur un projecteur qui n'était pas détecté en VGA, et là tout fonctionne normalement : le projecteur est détecté automatiquement.

Hors ligne

 

#20 16 Mar 2017 21:09:46

Luc Wachter
Modérateur
 
Lieu: Prilly
Date d'inscription: 01 Sep 2016
Messages: 200
Site web

Re: Connexion au projecteur ne fonctionne PLUS

Bonsoir,

@Patrice: C'est une bonne nouvelle. Personnellement, je déconseille l'utilisation du VGA au maximum possible. C'est une vieille interface pas très efficace, qui survit sûrement principalement grâce aux entreprises qui l'utilise beaucoup et qui ne veulent pas changer. Pouvez-vous utiliser l'HDMI dans le futur?

@gdeneyer: C'est embêtant, mais je m'en doutais. Mes recherches ne mènent nulle-part. Je commence à penser que le projecteur est mort... Je suis désolé de demander ça, mais comme des choses ont changés au travers de cette discussion, j'aimerais que vous refassiez les différents tests possibles.
1)Ce que ça affiche quand vous le branchez à votre why!
2)Ce qui se passe quand vous branchez votre écran à votre why! en VGA
3)Ce qui se passe quand le projecteur est branché à un autre appareil (Préciser si l'appareil est sous ubuntu, windows ou autre)

Désolé du dérangement, merci.


why! N240BU-Pro | i7-7500U | 8Go

Hors ligne

 

#21 16 Mar 2017 21:31:08

Patrice
Affranchi(e)
 
Date d'inscription: 14 Jan 2017
Messages: 9

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour.
Je ne peux pas utiliser les différents projecteurs en HDMI car ils sont posés au plafond et le câblage jusqu'au bureau est exclusivement en VGA. D'ailleurs la sortie VGA était pour cette raison un des critères pour acheter ce PC.
N'y a-t-il pas un pilote ou un correctif puisque au démarrage l'écran est reconnu et que tout se gâte quand Ubuntu démarre?
Merci.
Patrice.

Hors ligne

 

#22 17 Mar 2017 15:52:55

gdeneyer
Humain(e) libre
 
Date d'inscription: 08 Jun 2016
Messages: 31

Re: Connexion au projecteur ne fonctionne PLUS

Hello,

Pas de soucis, je comprends. Une chose est sûre, le projecteur n'est pas mort wink

1) Il ne s'affiche rien. Seul moyen, forcer la sortie vga via les commandes xrandr précisées plus haut. Même via xrandr, pas moyen d'avoir un affichage étendu.
2) Rien ne se passe avec l'écran
3) Testé sur deux appareils :
- un ordinateur ASUS qui tourne sur Ubuntu 16.04
- un macbook pro via adaptateur VGA-Thunderbolt
Dans les deux cas, le projecteur fonctionne correctement (reconnu dès la connexion).

Cordialement,
Gilles De Neyer

Hors ligne

 

#23 22 Mar 2017 22:04:52

Luc Wachter
Modérateur
 
Lieu: Prilly
Date d'inscription: 01 Sep 2016
Messages: 200
Site web

Re: Connexion au projecteur ne fonctionne PLUS

Bonsoir,

Merci de votre patience!

J'étais convaincu d'un problème logiciel puisque la sortie VGA fonctionnait sur votre moniteur. Cependant, maintenant que vous dites que rien ne se passe avec l'écran, je commence à penser au problème physique...

Pour s'en assurer, nous allons encore utiliser quelques commandes xrandr. Je sais que vous en avez déjà essayé, avec un succès moyen, mais nous allons voir ce que celles-ci donnent:

Code:

xrandr --output DP-1  --mode 1024x768
xrandr --output eDP-1 --mode 1920x1080
xrandr --output DP-1 --right-of eDP-1

Merci, et désolé pour l'attente.


why! N240BU-Pro | i7-7500U | 8Go

Hors ligne

 

#24 28 Mar 2017 17:49:33

gdeneyer
Humain(e) libre
 
Date d'inscription: 08 Jun 2016
Messages: 31

Re: Connexion au projecteur ne fonctionne PLUS

Je viens de voir votre réponse. Je vais essayer ces commandes demain avec mon projecteur. Entre temps l'écran externe fonctionne (c'est aléatoire d'une fois à l'autre ... )

Hors ligne

 

#25 30 Mar 2017 11:33:51

Patrice
Affranchi(e)
 
Date d'inscription: 14 Jan 2017
Messages: 9

Re: Connexion au projecteur ne fonctionne PLUS

Bonjour.
J'ai de nouveau essayé ces instructions, mais en créant d'abord le mode pour l'écran externe sinon ça renvoie une erreur. Notez que les écrans s'appellent DP1 et eDP1 et non pas DP-1 et eDP-1 :

xrandr --addmode eDP1 1368x768
xrandr --output eDP1 --mode 1368x768

xrandr --addmode DP1 1368x768
xrandr --output DP1 --mode 1368x768 --right-of eDP1


Et ça fait toujours le même résultat : l'écran externe n'a pas de fond d'écran et les fenêtres laissent des traces au déplacement. De plus, un clic droit sur le fond n'ouvre aucun menu, contrairement à l'écran principal.
Cordialement,
Patrice.

Hors ligne

 

Pied de page des forums

Powered by FluxBB