Swisslinux.org

− The GNU/Linux crossroads in Switzerland −

 

Language

 

The Forum

You are not logged in.

#1 26 May 2008 23:14:54

thecaptain
Citoyen(ne)
 
From: Sierre
Registered: 27 Oct 2004
Posts: 16
Website

[X11][MouseWheel] Kye Systems Corp. Genius

Salut à tous smile

J'ai installé ma gentoo avec enlightenment. Tout roule nickel, sauf pour ma souris... J'ai une souis wireless de type Kye Systems Corp. que je branche en USB. Elle est reconnue et fonctionne parfaitement.

Toutefois, la roulette foire complètement sad Sitôt que je l'utilise, de temps en temps (1 fois sur 3 quand même !), le contenu défile à l'inverse : si je scroll vers le bas, le contenu dessend de 2-3 pixels, remonte de 1-2 pixels, redescend de 3-4 pixels, remonte de 3-4, ... bref c'est vraiment peu utilisable.

Après avoir fouillé un peu, il me semble que cela vient de l'option Protocol dans xorg.conf. Actuellement j'ai ceci :

Section "InputDevice"
    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "ImPS/2"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

J'ai essayé diverses valeur comme ExplorerPS/2 (le scroll va pas bien non plus), PS/2 (la souris bouge même pas), Microsoft (la souris bouge alétoirement), ... mais sans succès jusqu'a présent.

Si je fais un dmesg | grep Mouse

input,hidraw0: USB HID v1.00 Mouse [Genius Ergo 3000] on usb-0000:00:1d.2-1
input: ImPS/2 Logitech Wheel Mouse as /class/input/input5

et un lsusb :

Bus 002 Device 003: ID 1058:0901 Western Digital Technologies, Inc.
Bus 002 Device 001: ID 0000:0000 
Bus 007 Device 002: ID 0458:0050 KYE Systems Corp. (Mouse Systems)
Bus 007 Device 001: ID 0000:0000 
Bus 006 Device 001: ID 0000:0000 
Bus 005 Device 001: ID 0000:0000 
Bus 001 Device 002: ID 04f2:b018 Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 0000:0000 
Bus 004 Device 003: ID 147e:2016 
Bus 004 Device 002: ID 0a5c:2101 Broadcom Corp.
Bus 004 Device 001: ID 0000:0000 
Bus 003 Device 001: ID 0000:0000

Quels sont les paramètres que je peux essayer pour corriger mon Mouse Wheel ?

Merci d'avance !

@++

Offline

 

#2 27 May 2008 17:38:33

Eggman
Admin
From: Grand-Lancy(GE)
Registered: 17 Nov 2004
Posts: 1038
Website

Re: [X11][MouseWheel] Kye Systems Corp. Genius

La partie :

Code:

Option      "ZAxisMapping" "4 5 6 7"

me paraît vachement louche!

Tous les "clics" de la souris sont identifiés par un chiffre.
Pour les identifier, il te faut lancer

Code:

xev

et regarder ce qui en sort lorsque tu utilises la molette.

Ensuite tu reporte les chiffres qui sortent dans ton /etc/X11/xorg.conf, sous l'option "ZAxisMapping", en lieu et place du "4 5 6 7".

Tout devrait rentrer dans l'ordre.


"It always takes longer than you expect, even when you take into account Hofstadter's Law."
Douglas Hofstadter, Gödel, Escher, Bach: An Eternal Golden Braid

Offline

 

Board footer

Powered by FluxBB