Swisslinux.org

− The GNU/Linux crossroads in Switzerland −

 

Language

 

The Forum

You are not logged in.

#1 16 Feb 2021 15:59:58

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2260
Website

[Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

Bonjour,

Voir problème des ventilateurs qui s'emballent pour refroidir le CPU AMD Ryzen 7 3700X et la GPU NVidia GeForce RTX 2060: https://swisslinux.org/forum/viewtopic. … 51#p31651.

Avec un CPU présentant une TDP de 65 W et une carte graphique NVidia GeForce RTX 2060 qui consomme jusqu'à 160 W (total= 225 W), il n'est pas étonnant que la batterie qui dispose d'une capacité théorique de 62 Wh (ou 62 W pendant une heure) se vide rapidement.

A noter que l'utilitaire Moniteur système ne montre pas l'activité de la GPU et que les 16 coeurs du CPU Ryzen 7 3700X ne sont sollicités qu'à environ 10% en moyenne. Tout porte à croire que c'est la GPU qui consomme inutilement et qui demande à être refroidie...


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Offline

 

#2 16 Feb 2021 18:21:24

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2260
Website

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

Voilà, je viens d'installer Windows 10 sur un SSD Samsung 970 EVO Plus neuf, avec la clé de licence de mon collègue Doruk Uyar et en fournissant pleins d'indications relatives à mon compte Microsoft (dont j'ignorais l'existence; peut-être un ancien test).

La machine ventilait pas mal au début. Puis, j'ai aperçu un petit message sur la barre de menu du bas m'invitant à installer l'outil de paramétrage NVidia. Cela fait, il m'indiquait avoir bien repéré la carte GeForce RTX 2060 avec toutes ses spécifications.

J'ai réussi à installer Firefox et à en faire le navigateur par défaut, puis j'ai débranché l'alimentation et lancé une grosse vidéo 4K sur YouTube.

Les ventilateurs font peu de bruit et seul celui de la GPU tourne un peu.

Après 15 minutes, sans enclencher l'économiseur de batterie, la batterie est encore chargée à 85% et affiche une autonomie résiduelle de 1h20 (soit 1h35 au total, ce qui reste peu, mais toujours mieux que les 45 min. avec Ubuntu 20.04).

J'ai ainsi vu ce que j'avais à voir et il ne me reste plus qu'à trouver les bons pilotes Linux pour la carte graphique...


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Offline

 

#3 16 Feb 2021 18:34:55

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2260
Website

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

De retour sur Ubuntu 20.04 (il faut passer par F2 et Boot manager), je viens de relancer la même vidéo 4K. La batterie n'est plus chargée qu'à 66% et affiche une autonomie de 40 minutes (soit 1h à pleine charge).

En revanche, les ventilateurs sont calmes et, comme sous Windows 10, il me semble que seul le ventilateur de la GPU tourne un peu.


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Offline

 

#4 16 Feb 2021 18:43:57

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2260
Website

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

Zut alors! En voulant réduire le rétroéclairage de l'écran pour améliorer l'autonomie de la batterie, je m'aperçois d'un autre problème: on ne peut pas réduire le rétroéclairage ni avec [Fn]+[F8], ni via le menu déroulant en haut à droite (le curseur bouge, mais sans effet). Pourtant, cela fonctionne très bien pour le son!?!

Au secours!


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Offline

 

#5 22 Feb 2021 16:05:50

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2260
Website

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

Une revendeur Clevo en Allemagne annonce, pour une machine similaire (NH55AFW) dotée de la même carte graphique RTX 2060, une autonomie maximale de 2 heures:

https://blog.whyopencomputing.ch/wp-content/uploads/2021/02/2021.02.22_Clevo-Europe_max.2h.png

Cette autonomie correspond bien à ce que l'on observe avec notre NV57ADS sous Windows 10. Reste à arriver au même résultat avec Ubuntu 20.04...


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Offline

 

#6 22 Feb 2021 16:30:16

ekimia
Humain(e) libre
Registered: 16 Apr 2014
Posts: 32

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

Bonjour françois,

Je te conseil de basculer en mode radeon via nvidia settings , de verifier l'autonomie , et de lancer une application "sur la carte dédiée" si tu veux utiliser la carte Nvidia

Pour mieux gerer la ventilation , il faut converger ensemble pour adapter un outil comme l'as fait Tuxedo  https://www.tuxedocomputers.com/en/TUXE … ter.tuxedo

Car les profils de ventilation du Bios clevo sont nuls

Last edited by ekimia (22 Feb 2021 17:01:38)

Offline

 

#7 23 Feb 2021 11:06:54

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2260
Website

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

Hello Michel,

En effet, le Tuxedo Control Center semble gérer l'ensemble de ces problèmes. Mais il faut l'installer depuis leur dépôt Github (https://github.com/tuxedocomputers/tuxe … rol-center). Je ne sais pas trop comment m'y prendre, mais je vais lire le readme...


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Offline

 

#8 23 Feb 2021 11:41:12

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2260
Website

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

En suivant, les instructions de la page readme, j'ai ouvert une fenêtre terminal ([Ctrl]+[Alt]+[T]) et passé les commandes suivantes:

Code:

curl -sL https://deb.nodesource.com/setup_12.x | sudo -E bash -
La commande « curl » n'a pas été trouvée, mais peut être installée avec : sudo apt install curl

J'ai donc installé curl:

Code:

sudo apt install curl

puis, à nouveau:

Code:

curl -sL https://deb.nodesource.com/setup_12.x | sudo -E bash -

## Installing the NodeSource Node.js 12.x repo...

Puis:

Code:

sudo apt install -y git gcc g++ make nodejs

Et clone & install libraries:

Code:

git clone https://github.com/tuxedocomputers/tuxedo-control-center.git

(NB: Il m'a fallu un petit moment pour comprendre qu'il fallait supprimer l'accent grave à la fin de la ligne.)

Ceci fait, un dossier tuxedo-control-center avait été créé dans le home et il était possible de s'y déplacer pour passer la commande suivante:

Code:

cd tuxedo-control-center
npm install

Je n'ai pas compris la signification du message:
Note: Do not continue with npm audit fix. Known to cause various issues.
Je l'ai donc ignoré.

Et me voici bloqué à l'étape 3:
Install service file that points to development build path (or use installed service from packaged version)

Manual instructions:
    Copy tccd.service and tccd-sleep.service (from src/dist-data) to /etc/systemd/system/
    Edit the tccd.service (exec start/stop) to point to <dev path>/dist/tuxedo-control-center/data/service/tccd.
    Copy com.tuxedocomputers.tccd.conf to /usr/share/dbus-1/system.d/
    Start service systemctl start tccd. (And enable for autostart systemctl enable tccd tccd-sleep)

J'ai tenté de copier les deux premiers fichiers depuis tuxedo-control-center/src/dist-data vers /etc/systemd/system/ en ouvrant deux fenêtres et en affichant les fichiers cachés, mais le système me dit que je n'ai pas les droits pour cela. Merci pour l'aide...

Suivant mon instinct, j'ai tenté de lancer les différents services en commençant par le premier:

Code:

npm run build

puis:

Code:

npm run start
npm run start-watch
npm run test-common
npm run gen-lang
npm run inc-version-patch
npm run inc-version-minor
npm run inc-version-major

J'ai cependant renoncé à créer un paquet .deb avec la commande npm run pack-prod -- all | deb | rpm, car je ne suis pas sûr de savoir ce que cela ferait...

Lorsque je lance TCC avec:

Code:

npm run start

La fenêtre s'ouvre un bref instant et l'icône s'affiche en haut à droite, mais il est juste possible de cliquer sur Exit. Peut-être suffit-il de redémarrer...

Malheureusement, cela ne change rien. Je vais donc tenter de créer un paquet .deb et de l'installer:

Code:

npm run pack-prod -- all | deb

Mais le script me renvoie plein d'erreur que je suis bien en peine d'interpréter:

Code:

npm run pack-prod -- all | deb

La commande « deb » n'a pas été trouvée, voulez-vous dire :

  commande « dub » du snap dub (1.19.0)
  commande « den » du snap den (1.2.0-0)
  commande « edb » du deb edb-debugger (1.0.0-1build3)
  commande « derb » du deb icu-devtools (66.1-2ubuntu2)
  commande « dex » du deb dex (0.8.0-2)
  commande « dab » du deb bsdgames (2.17-28build1)
  commande « dep » du deb go-dep (0.5.4-3)
  commande « debi » du deb devscripts (2.20.2ubuntu2)
  commande « dub » du deb dub (1.19.0-1build2)
  commande « deb3 » du deb quilt (0.65-3)
  commande « debc » du deb devscripts (2.20.2ubuntu2)

Voir « snap info <nomdusnap> » pour des versions supplémentaires.

events.js:291
      throw er; // Unhandled 'error' event
      ^

Error: write EPIPE
    at afterWriteDispatched (internal/stream_base_commons.js:156:25)
    at writeGeneric (internal/stream_base_commons.js:147:3)
    at Socket._writeGeneric (net.js:787:11)
    at Socket._write (net.js:799:8)
    at doWrite (_stream_writable.js:403:12)
    at writeOrBuffer (_stream_writable.js:387:5)
    at Socket.Writable.write (_stream_writable.js:318:11)
    at Socket.ondata (_stream_readable.js:718:22)
    at Socket.emit (events.js:314:20)
    at addChunk (_stream_readable.js:297:12)
Emitted 'error' event on Socket instance at:
    at errorOrDestroy (internal/streams/destroy.js:108:12)
    at Socket.onerror (_stream_readable.js:754:7)
    at Socket.emit (events.js:314:20)
    at errorOrDestroy (internal/streams/destroy.js:108:12)
    at onwriteError (_stream_writable.js:418:5)
    at onwrite (_stream_writable.js:445:5)
    at internal/streams/destroy.js:50:7
    at Socket.dummyDestroy [as _destroy] (internal/bootstrap/switches/is_main_thread.js:97:3)
    at Socket.destroy (internal/streams/destroy.js:38:8)
    at afterWriteDispatched (internal/stream_base_commons.js:156:17) {
  errno: 'EPIPE',
  code: 'EPIPE',
  syscall: 'write'
}
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! tuxedo-control-center@2.0.0 build-prod: `run-s clean build-electron build-service build-native build-ng-prod copy-files`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the tuxedo-control-center@2.0.0 build-prod script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/philpion/.npm/_logs/2021-02-23T11_15_48_922Z-debug.log
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! tuxedo-control-center@2.0.0 pack-prod: `npm run build-prod && ts-node ./build-src/electron-builder.ts "all"`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the tuxedo-control-center@2.0.0 pack-prod script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/philpion/.npm/_logs/2021-02-23T11_15_48_939Z-debug.log

Je dois malheureusement m'arrêter là pour le moment...


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Offline

 

#9 23 Feb 2021 15:25:27

ekimia
Humain(e) libre
Registered: 16 Apr 2014
Posts: 32

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

Je suis toujours étonné par ta démarche :-)

Tu essaie de compiler leur projet au lieu de l'installer

voila comment faire en quelques  lignes

Code:

wget https://raw.githubusercontent.com/tuxedocomputers/tuxedo.sh/master/keys/ubuntu.pub

sudo apt-key add ubuntu.pub

echo "deb http://deb.tuxedocomputers.com/ubuntu focal main" |sudo tee -a /etc/apt/sources.list.d/tuxedo-computers.list

sudo apt update

sudo apt install tuxedo-control-center

Last edited by ekimia (23 Feb 2021 15:26:36)

Offline

 

#10 23 Feb 2021 17:26:28

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2260
Website

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

YES!!!

Un grand merci à toi, Michel, ça a fonctionné comme sur des roulettes.

Après redémarrage, l'icône TUXEDO Control Center s'affiche tout en haut à droite, j'ai pu l'ouvrir, voir dans le Dashboard que c'est bien le ventilateur du CPU qui tourne vite dès que la température dépasse 40 degrés. Puis, dans Profiles, j'ai choisi la version Powersave extreme et enregistré ce choix (icône de la disquette) et les ventilateurs se sont tus.

Problème de ventilateurs [Résolu], donc.

Reste plus qu'à vérifier l'impact sur l'autonomie de la batterie...


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Offline

 

#11 24 Feb 2021 09:22:20

ekimia
Humain(e) libre
Registered: 16 Apr 2014
Posts: 32

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

En fait je te conseille surtout de faire ton propre profil avec les 2 ventilateurs ( y compris celui de la carte graphique ) en mode "quiet" , tu peux nous mettre une copie d'ecran au repos ?

Offline

 

#12 24 Feb 2021 14:48:20

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2260
Website

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

Bon, on n'entend plus les ventilateurs, mais, avec le profil Powersave extreme, l'autonomie annoncée au début d'une grosse vidéo est de 1h17. Ce qui est déjà mieux que 45 min.

Tuxedo Control Center permet de créer un profil personnalisé et de brider encore plus la fréquence du CPU pour atteindre l'autonomie de 2h constatée sous Windows...

Dans ces conditions, je me permets de marquer le problème comme [Résolu], car il ne sera probablement pas possible de faire beaucoup mieux...


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Offline

 

#13 24 Feb 2021 15:02:38

François Marthaler
Modérateur
From: Prilly
Registered: 07 Sep 2013
Posts: 2260
Website

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

@ekimia

Voici encore une capture d'écran du profil Powersave extreme:

https://blog.whyopencomputing.ch/wp-content/uploads/2021/02/2021.02.24_Profile_Powersaver_extreme.png

Les ventilateurs sont sur Silent (ce qui doit être encore plus faible que Quiet).

On outre, contrairement à ce que j'imaginais au post précédent, il n'est pas possible de créer un nouveau profil avec une fréquence du CPU inférieure à 2.2 GHz:

https://blog.whyopencomputing.ch/wp-content/uploads/2021/02/2021.02.24_Min.2.2GHz.png


laptop why! N240JU-PRO, Intel Core i7-6500U, RAM 8 Gb, Ubuntu 16.04 LTS

Offline

 

#14 25 Feb 2021 17:38:32

ekimia
Humain(e) libre
Registered: 16 Apr 2014
Posts: 32

Re: [Résolu] Autonomie de 45 min. avec why! Ryzen NH57ADS

Attention a l'utilisation de SIlent qui pourrait faire tellement chauffer que la performance sera tres mauvaise , voire dangereux !

Offline

 

Board footer

Powered by FluxBB